Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.13.2] Cannot get config value without assigned Config object present


Recommended Posts

Hi there,

I'm trying to setup my config but everytime i try to use it i get that issue: Cannot get config value without assigned Config object present

Mod class:

@Mod(BetterDiving.MOD_ID)
public class BetterDiving {
	
	public static final String MOD_ID = "better_diving";
	
	public BetterDiving() {
		ModLoadingContext.get().registerConfig(ModConfig.Type.COMMON, BetterDivingConfig.SPEC);
	}
}

 

Config class:

public class BetterDivingConfig {
	private static final ForgeConfigSpec.Builder BUILDER = new ForgeConfigSpec.Builder();
	public static final General GENERAL = new General();
	public static final ForgeConfigSpec SPEC = BUILDER.build();
	
	public static class General {
		public ConfigValue<Boolean> test;
		
		public General() {
			BUILDER.push("General");
			test = BUILDER.comment("Test!").define("test", false);
			BUILDER.pop();
		}
	}
}

 

Edited by Meldexun
Link to post
Share on other sites

So i get the issue when i try to use a config value. For example i use:

BetterDivingConfig.GENERAL.test.get()

And when looking into the ConfigValue#get() method that it calls Preconditions#checkNotNull() with spec.childConfig as an argument to check and because in my config the childConfig field is null i get the error.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.