Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.12.2] Break speed event


Recommended Posts

I noticed when there are multiple break speed events it can get buggy.

What i mean is the first break speed event sets the new speed to the original speed * 0.5F.

Then the second event tries to do something similar. For example it sets the new speed to the original speed * 1.3F.

The problem is that both events take the original speed as basis. So when the original speed is 1 then the new speed would be 1.3 but the correct value would be 0.65.

So i should always take the new speed as my base value and do my calculation. And then set the new speed to my calculated speed.

But if another mod has a break speed event which is fired after my event and it  uses the original speed as a base value then my calculations are completely ignored.

What can i do to prevent this? Setting the event prioriy to low or lowest is the only thing that i can think of.

Edited by Meldexun
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.