Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.12.2] Server Randomly Freezes


Recommended Posts

Greetings, i have a little Problem and dunno how to solve it.

Iam Hosting a small modded Minecraftserver for me and some friends. Now the Server seems to randomly freeze.
Every Player is timing out, server itself dont seems to crash. There are also no log entrys and no crash logs. When i open the screen session, the server looks fine but when i enter something like save-all, no response.

All i can do then is to force it stop and restart it. That drives me a bit crazy xD

I hope someone can help me to figure out whats the problem.

 

Versions

Minecraft Version: 1.12.2
Forge Version: forge-1.12.2-14.23.5.2838-universal

 

Server Specs:
16gb DDR4 RAM
AMD Ryzen 5 2400G

 

If there is some more specific things needed to know, please tell me.

Thx in advance

Link to post
Share on other sites

like i already wrote, there is nothing in the log. its liek the server worked normal. When it stops (freeze) also no log things appear, cause it doesnt write any log. But i added it anyway. it happened at the end of the log ofc.

Edited by Caaruzo
Link to post
Share on other sites

i try to but the site wont let me add the debug log (70.5mb) and zipped also wont work. it says error -200. file is also to large for pastebin.

 

edit: do you mind if i add it to gdrive? ( https://drive.google.com/drive/folders/1V3RjnaRpUUXaXc65vjpLSKw7tmfC7A2z?usp=sharing )

 

Server Stopping ad end of debug log is cause i killed screen session (ctrl+c)

Edited by Caaruzo
Link to post
Share on other sites
2 hours ago, diesieben07 said:

One thing I can tell you is that "Playerlogger" is completely spamming the log file (> 500 messages every second). Try removing it.

disabled it now. Will take a look onto and tell you then if it resolved the problem or not. Thx much.

Link to post
Share on other sites
  • 2 weeks later...

uff y i wanted to update them now, i found this: it seems to be the reason i think.

 

[05:01:17] [Server thread/ERROR] [Galacticraft]: POTENTIAL BIOME ID CONFLICT for id 147 conflicting with Galacticraft
[05:01:17] [Server thread/ERROR] [Galacticraft]: PLEASE CHECK CONFIGS FOR BOTH MODS: see Galacticraft core.conf setting BiomeIDBase
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: java.lang.Exception: Stack trace
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at java.lang.Thread.dumpStack(Thread.java:1336)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at micdoodle8.mods.galacticraft.api.prefab.world.gen.BiomeAdaptive.reportBiomeIDconflict(BiomeAdaptive.java:385)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at micdoodle8.mods.galacticraft.api.prefab.world.gen.BiomeAdaptive.func_180624_a(BiomeAdaptive.java:219)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at net.minecraft.world.gen.ChunkGeneratorFlat.func_185931_b(ChunkGeneratorFlat.java:214)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at com.rwtema.extrautils2.compatibility.SpecialDimCompat.populate(SpecialDimCompat.java:91)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at com.rwtema.extrautils2.dimensions.workhousedim.WorldProviderSpecialDim.generate(WorldProviderSpecialDim.java:350)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at com.rwtema.extrautils2.dimensions.workhousedim.WorldProviderSpecialDim.prepareNewChunk(WorldProviderSpecialDim.java:280)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at com.rwtema.extrautils2.quarry.TileQuarry.getNextChunk(TileQuarry.java:428)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at com.rwtema.extrautils2.quarry.TileQuarry.getNewChunk(TileQuarry.java:420)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at com.rwtema.extrautils2.quarry.TileQuarry.advance(TileQuarry.java:409)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at com.rwtema.extrautils2.quarry.TileQuarry.func_73660_a(TileQuarry.java:307)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at net.minecraft.world.World.func_72939_s(World.java:1838)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at net.minecraft.world.WorldServer.func_72939_s(WorldServer.java:613)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:767)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:397)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:668)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:526)
[05:01:17] [Server thread/INFO] [STDERR]: [java.lang.Thread:dumpStack:1336]: 	at java.lang.Thread.run(Thread.java:748)

 

is there an way to check existing ids? cause i thopugt there wont be any id conflicts in 1.12.2 anymore, lol

Link to post
Share on other sites

thats kinda freaky. changed the BiomeBaseID in core.cfg to 250 now. well see if thats the isse. Will check it a while again xD

 

And thx again ofc.

 

Edit:

 

The issue still exists. It almost always seems to happen when server resumes from hibernation, but also randomly sometimes on run. I updated the log files:

 

https://drive.google.com/drive/folders/1V3RjnaRpUUXaXc65vjpLSKw7tmfC7A2z?usp=sharing

Edited by Caaruzo
Link to post
Share on other sites
  • 4 weeks later...
On 11/10/2019 at 3:40 AM, Caaruzo said:

no one? :(

My custom server I run for me and my friends is doing this same thing, randomly freezes up and drops all my friends out, I have to hard kill the server to bring it back sometimes, maybe we can compare mods to see what we are both using to help us narrow it down? It sucks because I to am not getting any logs.

Link to post
Share on other sites
  • 2 months later...

I think, windows is freezing the task(java), because its idle. Im not 100% sure and wont explain why it happens while you're on the server, but its worth to research it.

Im doing it aswell and inform you of any updates

 

 

Edited by Slothy4K
Link to post
Share on other sites
Guest
This topic is now closed to further replies.


  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • sorry i will talk in english. there is the debug.log of server and the client debug.log debug.log
    • Aww thanks i guess... Makes sense now.
    • I showed you that code...    it was this, and your 'complained' about the deferred register name, then went on about Objectholder (which to be fair was only there because the ONLY other example of doing this wasn't exactly knowledgeable as to what was happening or why. I'm trying to figure out why the following works, and the example wasn't exactly updated, so i had to use IDE feedback to get it to work properly, and I used setRegistryName as a way to prevent it from using my own name space....    -- To be clear i'm not sure what i did that caused it to work..  but it does Just to be clear  This is sitting where the package says it's sitting.   -mine are sitting in com.dephoegon.reclaim....   package net.minecraft; import com.dephoegon.reclaim.aid.block.sand; import net.minecraft.block.AbstractBlock; import net.minecraft.block.Block; import net.minecraft.block.SoundType; import net.minecraft.block.material.Material; import net.minecraft.block.material.MaterialColor; import net.minecraft.item.BlockItem; import net.minecraft.item.Item; import net.minecraft.item.ItemGroup; import net.minecraftforge.common.ToolType; import net.minecraftforge.event.RegistryEvent; import net.minecraftforge.eventbus.api.SubscribeEvent; import net.minecraftforge.fml.common.Mod; import net.minecraftforge.registries.ObjectHolder; @Mod.EventBusSubscriber(bus=Mod.EventBusSubscriber.Bus.MOD) public class blockoverrides { public static final Block SAND = new sand(14406560, AbstractBlock.Properties.create(Material.SAND, MaterialColor.SAND) .harvestTool(ToolType.SHOVEL).harvestLevel(0) .hardnessAndResistance(0.5F).sound(SoundType.SAND) , "", "", "", true).setRegistryName("minecraft", "sand"); @SubscribeEvent public static void onBlocksRegistry(final RegistryEvent.Register<Block> blockRegistryEvent) { blockRegistryEvent.getRegistry().registerAll ( SAND ); } public static final Item SAND_ITEM = new BlockItem(SAND, new Item.Properties().group(ItemGroup.BUILDING_BLOCKS)).setRegistryName("minecraft","sand"); @SubscribeEvent public static void registerItems(RegistryEvent.Register<Item> event) { event.getRegistry().registerAll ( SAND_ITEM ); } }  
    • From what I can .. gather, and I'm sure this is my confusion going on..        It has public Objects that are effectively the block registry calls. Wait?  Would it be possible to actually override a public object, and have it use it? ---      I'm not sure I understand,   though the only bit I can honestly gather from that is a string name key, & the block object calling a new instance of a block (sand, log, etc) with properties defined in those block classes, which are often calling abstractblocks for properties, and extending special classes (like fallingblock) which tend to fall onto blocks, then abstract blocks themselves.   perhaps I'm missing the forest for the trees (or missing the trees for the forest), but  I'm not getting how you meant that.
    • Oh hold on, I forgot about the refresh gradle option. I refreshed the project and it downloaded new jars. That's weird, the last time I opened the workspace and started the game, it was working fine. Sorry for wasting your time. 😓
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.