Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.14.4] Custom signs


Recommended Posts

Hi,

I am trying to make a custom sign but it isn't working. I'm not really trying to make a fully custom sign, I just want to have a new additional sign that uses a different texture but behaves the same as the regular signs. (I don't want to override the textures of the regular signs because I want them too). The 2 problems I have with my sign are: 1. No texture (not sure where the texture for signs is declared but blockstate and model jsons do not have them and I haven't been able to find them in code), 2. When placing the sign, it doesn't open the sign GUI.

The way I coded it was as follows:

Registered blocks:

MyBlocks.metal_sign = new StandingSignBlock(Block.Properties.create(Material.WOOD).doesNotBlockMovement().hardnessAndResistance(1.0F).sound(SoundType.WOOD)).setRegistryName(location("metal_sign")),
MyBlocks.metal_wall_sign = new WallSignBlock(Block.Properties.create(Material.WOOD).doesNotBlockMovement().hardnessAndResistance(1.0F).sound(SoundType.WOOD)).setRegistryName(location("metal_wall_sign"))

Registered item:

MyItems.metal_sign = new SignItem((new Item.Properties()).maxStackSize(16).group(ItemGroup.DECORATIONS), MyBlocks.metal_sign, MyBlocks.metal_wall_sign).setRegistryName(MyBlocks.metal_sign.getRegistryName())         

Created blockstate json for metal_sign & metal_wall_sign, created model json for metal_sign (I did this exactly like how acacia signs, oak signs, etc are done), created model item json as well.

I found the sign textures in textures/entities/signs and tried putting mine in the same folder (both under minecraft and under my mod's folder), but that didn't help. I get no errors in the debug log so I'm really confused why this isn't working. I did verify (using data get block) that my invisible sign does have a tile entity of the right type. Any help would be appreciated.

Thanks          

Link to post
Share on other sites

You need to show more of your code, preferably as a working git repo

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I may have simply needed to update the import. Sorry about that.
    • I'm using forge-1.17.1-37.0.15-mdk, and the empty project starts without any problems. I have no idea where the problem lies.
    • It happens with Language Support for Java. Because of this error, my code will not be able to resolve the reference. Please help me. Error Messages: ---------------------------------- [Warn  - 9:37:53] 2021/08/01 9:37:53 While loading class "org.eclipse.buildship.core.internal.util.gradle.PublishedGradleVersions$LookupStrategy", thread "Thread[Worker-1: Loading available Gradle versions,5,main]" timed out waiting (30035ms) for thread "Thread[pool-2-thread-1,5,main]" to finish starting bundle "org.eclipse.buildship.core_3.1.5.v20210112-1646-s [14]". To avoid deadlock, thread "Thread[Worker-1: Loading available Gradle versions,5,main]" is proceeding but "org.eclipse.buildship.core.internal.util.gradle.PublishedGradleVersions$LookupStrategy" may not be fully initialized. Unable to acquire the state change lock for the module: osgi.identity; type="osgi.bundle"; version:Version="3.1.5.v20210112-1646-s"; osgi.identity="org.eclipse.buildship.core"; singleton:="true" [id=14] STARTED [STARTED] org.osgi.framework.BundleException: Unable to acquire the state change lock for the module: osgi.identity; type="osgi.bundle"; version:Version="3.1.5.v20210112-1646-s"; osgi.identity="org.eclipse.buildship.core"; singleton:="true" [id=14] STARTED [STARTED]     at org.eclipse.osgi.container.Module.lockStateChange(Module.java:350)     at org.eclipse.osgi.container.Module.start(Module.java:419)     at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:511)     at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:117)     at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:572)     at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:345)     at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:401)     at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:480)     at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:170)     at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:519)     at org.eclipse.buildship.core.internal.util.gradle.PublishedGradleVersionsWrapper$LoadVersionsJob.run(PublishedGradleVersionsWrapper.java:60)     at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63) Caused by: java.util.concurrent.TimeoutException: Timeout after waiting 30 seconds to acquire the lock.     at org.eclipse.osgi.container.Module.lockStateChange(Module.java:347)     ... 11 more Caused by: org.eclipse.osgi.framework.util.ThreadInfoReport: Thread dump ... ----------------------------------  
    • Can someone please tell me why this is happening and help me find a solution. thanks. Edit: Nevermind I figured it out.
    • I am trying to store data through my ItemStack capability storage, but I stumbled upon a roadblock. My ItemStack Capability Storage: public class WandItemStorage implements Capability.IStorage<IWandCap> { @Nullable @Override public INBT writeNBT(Capability<IWandCap> capability, IWandCap instance, Direction side) { CompoundNBT tag = new CompoundNBT(); tag.put("spells", instance.getSpells()); return tag; } @Override public void readNBT(Capability<IWandCap> capability, IWandCap instance, Direction side, INBT nbt) { } } My ItemStack Capability: public class WandCap implements IWandCap { private List<Spell> spells; public WandCap () { spells = new ArrayList<>(); } @Override public List<Spell> getSpells() { return this.spells; } @Override public void addSpells(Spell... spells) { this.spells.addAll(Arrays.asList(spells)); } @Override public void addSpell(Spell spell) { this.spells.add(spell); } @Override public void removeSpells(Spell... spells) { this.spells.removeAll(Arrays.asList(spells)); } @Override public void removeSpell(Spell spell) { this.spells.remove(spell); } @Override public boolean containsSpell(Spell spell) { return this.spells.contains(spell); } } I'm currently trying to put a List of Spells (my custom object) to the Write and Read NBT methods of my ItemStack cap storage, but CompoundNBT doesn't have a method for putting a custom object into a tag. All it has is the put() method from what I'm seeing, however the put() method requires an INBT for the second parameter, which I do not have. Would I need to convert my List of Spells to an INBT, and how would I go about doing that?
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.