Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

genIntelliJruns in IDEA doesn't generate debug configurations:SOLVED


TheGreyGhost
 Share

Recommended Posts

Howdy folks

I'm just returning to modding after a break (since 1.12.2) and I'm having trouble getting started with the MDK for 1.14.4.

I've imported the project using gradle.build and then executed genIntelliJRuns, and it appears to have worked except that the debug configurations are missing from IDEA's Run menu.

I can run the project using the gradle task runClient, but I can't debug it.

Any clues?

TGG

----------------------

Never mind - I found a solution; I need to right click on the runClient gradle task which gives me the option to debug.

Edited by TheGreyGhost
Found solution myself
Link to comment
Share on other sites

First of all - Big fan, your MBE repo has helped me tons!

Why not go directly to 1.15.2?

1 hour ago, TheGreyGhost said:

I need to right click on the runClient gradle task which gives me the option to debug.

I’m not sure what you mean by this but use your run configs instead of the gradle tasks for this exact reason. I’ve got a tutorial for setting up your workspace at https://cadiboo.github.io/tutorials/1.14.4/forge/1.1-importing-project/intellij/

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

Thanks Cadiboo :)

>Why not go directly to 1.15.2?

The main reason is that a lot of the changes from 1.12.2 seem to be pretty big and I want to be sure that I don't waste hours debugging problems that turn out to be Forge 1.15.2 Beta issues.  I'm thinking that the update from 1.14.4 to 1.15.2 will be much easier.  But that might be wishful thinking :(

 

>I’m not sure what you mean by this but use your run configs instead of the gradle tasks for this exact reason.

Yeah I always used to do it that way: gradlew setupDecompWorkspace idea and gradlew genIntelliJruns;  but with 1.14.2 that no longer works, and genIntelliJruns doesn't seem to create any configurations on the Run menu like it used to.  I'm using a pretty old version of IDEA (14!) so that might have something to do with it.

 

I can use the gradle runClient to debug like the Run menu did so I think it should be ok.  I looked at your link (thanks for that) but it didn't generate the configurations how it did for you.

 

Cheers

  TGG

 

 

 

 

 

image.png

Link to comment
Share on other sites

34 minutes ago, TheGreyGhost said:

I'm using a pretty old version of IDEA (14!) so that might have something to do with it.

Probably, I know that it works on 18 and 19.

 

If you decide to update to 1.14.4 instead of 1.15.2 just leave rendering alone completely as it changed a lot in 1.15 and it’s not worth rewriting your code twice.

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

that's sounds ominous {sinking feeling in the pit of my stomach when I remember how much effort it took me to figure out rendering, especially for TileEntities}

Yeah I think I will update to 1.14.4 for the basic stuff only and then jump to 1.15.2 when it comes out of beta.  I think it's probably time to retire a few of the "fancier" topics now.  And I've brought myself up to speed on Entities using another project I'm working on so I might add that in as well.  Too many ideas not enough time :)

 

Thanks for the tip! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.