Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

(SOLVED) [1.14.4] Modify Vanilla Mob Spawning


Recommended Posts

for (Biome biome : ForgeRegistries.BIOMES) {
  
  biome.getSpawns(EntityClassification.CREATURE).clear();
  biome.getSpawns(EntityClassification.CREATURE).add(new Biome.SpawnListEntry(EntityType.PIG, 1, 3, 5)); 
}

 

I can clear all existing spawns from a biome using the clear method, which allows me to add a spawn exactly how I want, but then everything is gone. There are remove methods but they don't seem to be able to remove specific entities. Anyone know how to do this?

Edited by MineModder2000
Link to post
Share on other sites
  • 3 weeks later...
On 1/30/2020 at 1:32 AM, MineModder2000 said:

I'm old school, but I guess I can learn new tricks ?

 

PS : I just learned how to do it. 

I'm very new to modding and I can't seem to figure out how to do it... :(

Maybe I'm being really stupid, but how did you do it?

Edited by Xrated_junior
Link to post
Share on other sites
13 hours ago, MineModder2000 said:
Iterator<SpawnListEntry> biomeSpawns = biome.getSpawns(EntityClassification.CREATURE).iterator();
    			
while(biomeSpawns.hasNext()) {
	SpawnListEntry entry = biomeSpawns.next();
	if (entry.entityType == EntityType.PIG)
	{
		biomeSpawns.remove();
	}
}

 

Thank you! I will definitely look at that.  I did get it to work eventually. Don't know if it looks bad though... :) 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Alright, thanks once again for your support, have a great day
    • It works now, thank you very much. However, there is something else I'm wondering about. One mod, Netherite Plus, says that to config, I need to restart the game, but I did, twice, and the config option is still not available. (I use Mr. Crayfish's "Configured" to config mods). Do you know what's wrong?  
    • public static void generateOres(final BiomeLoadingEvent event) { if (!(event.getCategory().equals(Biome.Category.NETHER) || event.getCategory().equals(Biome.Category.THEEND))) { buildOreFeature(BlockInit.BERYLORE.get(), Blocks.GRASS, 10, 0, 100, 20); } } you're not actually adding the features to the biome, the return value of your method is just getting ignored, in mcp the method that you call is BiomeGenerationSettingsBuilder#withFeature, in mojmaps I don't know   private static ConfiguredFeature<?, ?> buildOreFeature(Block ore, Block filler, int maxVeinSize, int minVeinLevel, int maxVeinLevel, int spawnRate) { ConfiguredFeature<?, ?> feature = Feature.ORE.configured(new OreFeatureConfig(new BlockMatchRuleTest(filler), ore.defaultBlockState(), maxVeinSize)); feature = minMaxRange(feature, minVeinLevel, maxVeinLevel).squared(); feature = feature.count(spawnRate); return feature; } this is not how you should create a ConfiguredFeature 1- I suggest you keep each feature in a static field 2- you need to actually Register the feature, or the game won't know about it, you can do so by calling Registry.register, and registering your feature to the Configured Features registry which can be found under the class WorldGenRegistries 3- you can chain the count, squared and so on methods, it'll make your code look cleaner   MinecraftForge.EVENT_BUS.addListener(EventPriority.HIGH, ModOreGen::generateOres); There's no need set it to a high priority, and you're registering the listener to the wrong event bus
    • So basically I tried updating my 1.12.2 ore generation to 1.16.5, long story short theres a massive change. I finally got it without eclipse problems through looking at a couple githubs, but it doesnt work. I feel like im overlooking an obvious problem but I cant see it. If someone could help me out that'd be great. Heres my code for the ore gen. @Mod.EventBusSubscriber(modid = Main.MODID, bus = Mod.EventBusSubscriber.Bus.MOD) public class ModOreGen { public static void generateOres(final BiomeLoadingEvent event) { if (!(event.getCategory().equals(Biome.Category.NETHER) || event.getCategory().equals(Biome.Category.THEEND))) { buildOreFeature(BlockInit.BERYLORE.get(), Blocks.GRASS, 10, 0, 100, 20); } } private static ConfiguredFeature<?, ?> buildOreFeature(Block ore, Block filler, int maxVeinSize, int minVeinLevel, int maxVeinLevel, int spawnRate) { ConfiguredFeature<?, ?> feature = Feature.ORE.configured(new OreFeatureConfig(new BlockMatchRuleTest(filler), ore.defaultBlockState(), maxVeinSize)); feature = minMaxRange(feature, minVeinLevel, maxVeinLevel).squared(); feature = feature.count(spawnRate); return feature; } private static IDecoratable<ConfiguredFeature<?,?>> minMaxRange(IDecoratable<ConfiguredFeature<?,?>> f, int min, int max) { return f.decorated(Placement.RANGE.configured(new TopSolidRangeConfig(min, min, max))); } } And heres where I call it public Main() { IEventBus bus = FMLJavaModLoadingContext.get().getModEventBus(); bus.addListener(this::setup); ItemInit.ITEMS.register(bus); BlockInit.BLOCKS.register(bus); MinecraftForge.EVENT_BUS.register(this); MinecraftForge.EVENT_BUS.register(FuelHandler.instance); PotionList.EFFECTS.register(bus); PotionList.POTIONS.register(bus); MinecraftForge.EVENT_BUS.addListener(EventPriority.HIGH, ModOreGen::generateOres); }  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.