Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.15.1] Weird small type arms rendering when elytra flying?


SciPunk
 Share

Recommended Posts

 

Managed to change the player model for my custom elytra, however whenever I toggle the " Elytra Fly" some weird small arms appear even though I set their visibility to false, this is my code:

@SubscribeEvent
public static void onRenderPlayerPre(RenderPlayerEvent.Pre event) {
    PlayerEntity player = (PlayerEntity) event.getEntity();

    if (player.isElytraFlying() && player.getItemStackFromSlot(EquipmentSlotType.CHEST).getItem() == ItemHolder.BATMAN_CHEST) {



     event.getRenderer().getEntityModel().bipedRightArm.showModel = false;
        event.getRenderer().getEntityModel().bipedRightArmwear.showModel = false; 
     event.getRenderer().getEntityModel().bipedLeftArm.showModel = false;
        event.getRenderer().getEntityModel().bipedLeftArmwear.showModel = false;
        event.getRenderer().getEntityModel().bipedBody.showModel = false;




    }


}

 

The weird arms I got:

 2020-01-29_14_15_35.png.9e73e7bd7a2a65f56ac6b8f774898b7b.png2020-01-29_14_15_33.png.528bba66fa05206e04e1032dee14342c.png

Link to comment
Share on other sites

Sorry I can’t help more, but have you tried stepping through what’s happening in the debugger and seeing why the arms are being rendered?

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

20 hours ago, Cadiboo said:

Sorry I can’t help more, but have you tried stepping through what’s happening in the debugger and seeing why the arms are being rendered?

No worries thanks anyways, gonna check the debugger, I don't know why I didn't do that in the first place lol

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.