Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

trouble with importing gradle project


Recommended Posts


I am new to Minecraft modding with Forge and encountered a problem that does not seem to be solved anywhere in this forum.

What I did:

I want to mod for MC 1.14.4 (but: same problem with 1.15.2) so I downloaded the recommended .mdk zip-folder and unpacked it.

Then I started IntelliJ and selected "Open" and chose the build.gradle file.

IntelliJ then tried to build the project which resulted in an error (Could not start deamon because of the maximum heap size). So I tried solving this issue by changing the maximum heap size (in the gradle.properties file as well as in my IDE). This did solve my issue but when re-trying to import gradle project I encountered the following error:


Error: Could not create the Java Virtual Machine.

I have not found a working way to solve this issue.


What I use:

- JDK 1.8.0_241

- IntelliJ IDEA Ultimate 2019.3.3

- forge-1.14.4-28.2.0-mdk // forge-1.15.2-31.1.0-mdk


Any halp regarding this problem would be appreciated! Thanks a lot already!


Edited by jkcraft
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.