Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Fernflower decompiler not working?


Raeglyn
 Share

Recommended Posts

I am using Fernflower to decompile SereneSeasons. I actually already successfully did this, like.. last week. But then I deleted the decompiled files because I thought I didn't need them anymore.

Now I am trying to follow the instructions at Fernflower's github page, and it's not working anymore. The output of the file looks like a success:

 

frt099phu9q41.png?width=880&format=png&a

 

But the only thing in my destination folder is a copy of the original jar file??

 

hdskjnvnu9q41.png?width=798&format=png&a

 

I'm taking any pointers or suggestions. Thanks!

Link to comment
Share on other sites

There is no need to decompile the mod, as its source is public: https://github.com/Glitchfiend/SereneSeasons.

Some tips:

Spoiler

Modder Support:

Spoiler

1. Do not follow tutorials on YouTube, especially TechnoVision (previously called Loremaster) and HarryTalks, due to their promotion of bad practice and usage of outdated code.

2. Always post your code.

3. Never copy and paste code. You won't learn anything from doing that.

4. 

Quote

Programming via Eclipse's hotfixes will get you nowhere

5. Learn to use your IDE, especially the debugger.

6.

Quote

The "picture that's worth 1000 words" only works if there's an obvious problem or a freehand red circle around it.

Support & Bug Reports:

Spoiler

1. Read the EAQ before asking for help. Remember to provide the appropriate log(s).

2. Versions below 1.11 are no longer supported due to their age. Update to a modern version of Minecraft to receive support.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • hi i made the accesstransformer.cfg file with the text it needs for what im doing, but i dont know how to refresh the gradle project, in eclipse you right click in the project, gradle and refresh gradle project but im using intellij and all the tutorials for accesstransformers are made for eclipse #AbstractClientPlayerEntity public net.minecraft.client.entity.player.AbstractClientPlayerEntity field_175157_a # playerInfo #NetworkPlayerInfo public net.minecraft.client.network.play.NetworkPlayerInfo field_187107_a # playerTextures public net.minecraft.client.network.play.NetworkPlayerInfo field_178864_d # playerTexturesLoaded public net.minecraft.client.network.play.NetworkPlayerInfo func_178841_j()V # loadPlayerTextures public net.minecraft.client.network.play.NetworkPlayerInfo field_178867_a # gameProfile  
    • i wrote the accessmodifier thing, refreshed the build.gradle file and even restarted my idle but it didnt worked, i checked the location of where the .cfg file should be but there is nothing(src/main/resources/META-INF/accesstransformer.cfg), there is only the mods.toml
    • Did you had a look at the link to the Forge doc I attached?
    • I have a server on Forge, no mods installed, version 1.16.5.  If I try to do any update on a new release the placed block values randomize.  Basically, the grass turns to rail road tracks, horses are dolphins grazing grass, chickens are fish sliding around on the grass, and the ender dragon is raining fire and hell down on the world.  It's a interesting take on the game.  However, you can't play this scrambled mess.  The block will look correct in your hand, but once place it's anyone's guess what it becomes. There is literally zombie army's marching single file LOL...So the server is currently stuck on 1.16.5 and I can't update it basically.  If I reload my backup to the version 1.16.5 all order is restored.   I have updated my account, java, and reinstalled Minecraft.  Single player works fine on new world creations....it's just this server and trying to update.  It has been updated many times in the past, as it's a couple years old...any suggestions?
    • I know this is basic java knowledge but PLEASE tell me a solution, i already learned java but i never imagined how i can use public, private and protected(obviusly i use them but i dont know how to connect private fieds so my class) im BEGGING YOU tell me how, i tried some tutorials of how to access to private fields but it wasnt helpful
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.