Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Could not resolve: net.minecraftforge:forge


Cobiy
 Share

Recommended Posts

Trying to get gradle project setup for eclipse but i get this error
 

Could not resolve: net.minecraftforge:forge:1.15.2-31.1.0_mapped_snapshot_20190719-1.14.3

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.9/userguide/command_line_interface.html#sec:command_line_warnings


same error on latest forge for 1.15.2 can't get it to generate the project

Link to comment
Share on other sites

Step 1: Open your command-line and browse to the folder where you extracted the zip file.

Step 2: You're left with a choice.
If you prefer to use Eclipse:
1. Run the following command: "gradlew genEclipseRuns" (./gradlew genEclipseRuns if you are on Mac/Linux)
2. Open Eclipse, Import > Existing Gradle Project > Select Folder 

Link to comment
Share on other sites

4 minutes ago, Cobiy said:

1. Run the following command: "gradlew genEclipseRuns" (./gradlew genEclipseRuns if you are on Mac/Linux)

There is another command gradlew eclipse. However you opened the project as a gradle project as such I'm not sure how necessary it is. I always
gradlew eclipse
gradlew genEclipseRuns

Import Project as a Java Project.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

22 minutes ago, Animefan8888 said:

There is another command gradlew eclipse. However you opened the project as a gradle project as such I'm not sure how necessary it is. I always
gradlew eclipse
gradlew genEclipseRuns

Import Project as a Java Project.

Hi thank you for your reply, after installing a fresh mdk for 1.15.2 and doing gradlew eclipse in the directory i get the same error as the first time :/

Link to comment
Share on other sites

28 minutes ago, me1 said:

I'm not sure about eclipse but I think in IntelliJ you have to import the build.gradle file and not the folder. I could be wrong tho

Hi, thank you intellij idea proved to be better than eclipse for once.

Link to comment
Share on other sites

42 minutes ago, Cobiy said:

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.9/userguide/command_line_interface.html#sec:command_line_warnings

This isn't really a problem. From my experience it always says that. Was there an actual error?

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.