Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED!]My Ores are not generated


me1
 Share

Recommended Posts

So I have these Blocks(white_empty_block & black_empty_block) witch I want to spawn underground just like Ores. Sadly it isn't working. I don't know where the problem is. I added some logs and all methods I want to be called are called. Here are some parts of my code:

    @SubscribeEvent
    public static void loadCompleteEvent(FMLLoadCompleteEvent event)
    {
        BlockInit.onOreGeneration();
        OreGenerator.generateOre();
    }

// ^ This is in my main Class

public static void onOreGeneration()
    {
        Biome[] overWorld = getBiomes(BiomeDictionary.Type.OVERWORLD);
        OreGenerator.Ores.add(new OreGenerator.OreType(white_empty_block.getDefaultState(), overWorld, new CountRangeConfig(1180, 8, 8, 124), OreFeatureConfig.FillerBlockType.NATURAL_STONE, 2));
        OreGenerator.Ores.add(new OreGenerator.OreType(black_empty_block.getDefaultState(), overWorld, new CountRangeConfig(1140, 8, 8, 124), OreFeatureConfig.FillerBlockType.NATURAL_STONE, 2));
    }

//^ This is in my BlockInit

public class OreGenerator {
    public static class OreType {
        public final BlockState ore;
        public final Biome[] biomes;
        public final CountRangeConfig countRangeConfig;
        public final OreFeatureConfig.FillerBlockType fillerBlockType;
        public final int size;

        public OreType(BlockState ore, Biome[] biomesIn, CountRangeConfig countRangeConfig, OreFeatureConfig.FillerBlockType fillerBlock, int maxGroupSize) {
            this.ore = ore;
            biomes = biomesIn;
            this.countRangeConfig = countRangeConfig;
            fillerBlockType = fillerBlock;
            size = maxGroupSize;
        }
    }

    public static final ArrayList<OreType> Ores = new ArrayList<OreType>();

    public static void generateOre() {
        for (Object oreType : Ores.toArray())
            for (int i = 0; i < ForgeRegistries.BIOMES.getValues().size(); ++i) {
                for (Biome biomeCan : ((OreType) oreType).biomes)
                    if (ForgeRegistries.BIOMES.getValues().contains(biomeCan)) {
                        OreType ore = (OreType) oreType;
                        ConfiguredPlacement placement = Placement.COUNT_RANGE.configure(ore.countRangeConfig);
                        ((Biome)ForgeRegistries.BIOMES.getValues().toArray()[i]).addFeature(GenerationStage.Decoration.UNDERGROUND_ORES, Feature.ORE.withConfiguration(
                                new OreFeatureConfig(ore.fillerBlockType, ore.ore, ore.size)).withPlacement(placement));
                    }
            }
    }

    public static Biome[] getBiomes(BiomeDictionary.Type type) {
        Object[] _biomes = BiomeDictionary.getBiomes(type).toArray();
        Biome[] biomes = new Biome[_biomes.length];
        for (int i = 0; i < _biomes.length; ++i)
            biomes[i] = (Biome) _biomes[i];
        return biomes;
    }
}

//^ This is My OreGenerator Class

 

Please help.

Edited by me1
SOLVED
Link to comment
Share on other sites

1 hour ago, me1 said:

for (int i = 0; i < ForgeRegistries.BIOMES.getValues().size(); ++i) {
	for (Biome biomeCan : ((OreType) oreType).biomes)
		if (ForgeRegistries.BIOMES.getValues().contains(biomeCan)) {
			OreType ore = (OreType) oreType;
			ConfiguredPlacement placement = Placement.COUNT_RANGE.configure(ore.countRangeConfig);
			((Biome)ForgeRegistries.BIOMES.getValues().toArray()[i]).addFeature(GenerationStage.Decoration.UNDERGROUND_ORES, Feature.ORE.withConfiguration(new OreFeatureConfig(ore.fillerBlockType, ore.ore, ore.size)).withPlacement(placement));
		}
}
    

 

What are you trying to do here?

You iterate every biome for the oreType for every biome in the game.

News flash

Quote

(Biome)ForgeRegistries.BIOMES.getValues().toArray()

This is not the biome that you want to add it to. Right now your code will try to add it to every biome.

 

1 hour ago, me1 said:

FMLLoadCompleteEvent

This is not the correct event to do this in. You should be doing this in the FMLCommonSetupEvent.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

I change the whole double loop nonesence, translated the FMLLoadCompleteEvent to to FMLCommonSetupEvent and added it to DefferedWorkQueue and... it still soesn't work :(

Here is some more information some might find usefull:

-I don't you Deferred Registers. I use the othe method(dunno how it's called).

-I also can't find my biomes.

-The blocks work when. I can place them, I can craft them, I just can't find them under the ground(I seearched for multiple minuets)

Link to comment
Share on other sites

5 minutes ago, me1 said:

I change the whole double loop nonesence, translated the FMLLoadCompleteEvent to to FMLCommonSetupEvent and added it to DefferedWorkQueue and... it still soesn't work

Post your new code.

 

5 minutes ago, me1 said:

-I don't you Deferred Registers. I use the othe method(dunno how it's called)

Registry Events?

 

5 minutes ago, me1 said:

-I also can't find my biomes.

Did you tell them to generate? Also a separate issue.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

Here's my new code:

private void setup(final FMLCommonSetupEvent event) {
        for(int i = 0; i < 5000; ++i)
            LOGGER.info("SETUP");
        BlockInit.onOreGeneration();
        OreGenerator.generateOre();
    }

    public static void deferredWorkQueue(DeferredWorkQueue  queue)
    {
        for(int i = 0; i < 5000; ++i)
            LOGGER.info("SETUP");
        BlockInit.onOreGeneration();
        OreGenerator.generateOre();
    }

//^ MainClass Updated

public static void generateOre() {
        for (Object oreType : Ores.toArray())
                for (int i = 0; i < ((OreType)oreType).biomes.length; ++i)
                    {Biome biome = ((OreType)oreType).biomes[i];
                        OreType ore = (OreType) oreType;
                        ConfiguredPlacement placement = Placement.COUNT_RANGE.configure(ore.countRangeConfig);
                        biome.addFeature(GenerationStage.Decoration.UNDERGROUND_ORES, Feature.ORE.withConfiguration(
                                new OreFeatureConfig(ore.fillerBlockType, ore.ore, ore.size)).withPlacement(placement));
                    }
    }

//^ OreGenerator Updated

Link to comment
Share on other sites

6 minutes ago, me1 said:

public static void deferredWorkQueue(DeferredWorkQueue queue) { for(int i = 0; i < 5000; ++i) LOGGER.info("SETUP"); BlockInit.onOreGeneration(); OreGenerator.generateOre(); }

This is not what using DeferredWorkQueue means. You need to use DeferredWorkQueue.runLater to run your code on the main thread.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hello, I run a server on Apex and have found that every time we close out of the client and log back in, all our keys bindings are reset. It's terribly annoying. I removed mods one by one and they did not seem to cause the issue. Had tech support check the server, and nothing. It does not occur on my 1.16.5 server (run with forge). I am thinking it is a bug with the current forge. Any fixes? 
    • I've been trying to load a custom modpack but it's not letting me create any worlds, it keeps giving me the error "Errors in currently selected datapacks prevented the world from loading. You can either try to load it with only the vanilla data pack ("safe mode") or go back to the title screen to manually fix it". Any way to fix this without needing to remove too many mods? debug log: https://gist.github.com/antxasil/71401fb6a004a66e7248d04d8e7af589
    • I've used forge before, but I can't get it to work with 1.18+   Launcher code: [0116/225441.672:INFO:main_context.cpp(136)] CEF initialized successfully. [0116/225441.673:INFO:main_context.cpp(138)] CEF version: 85.3.13+gcd6cbe0+chromium-85.0.4183.121 [0116/225502.918:WARNING:angle_platform_impl.cc(48)] compileToBinary(257):  C:\fakepath(107,1-13): warning X3557: loop only executes for 1 iteration(s), forcing loop to unroll C:\fakepath(102,1-13): warning X3557: loop only executes for 1 iteration(s), forcing loop to unroll [0116/225508.369:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225515.224:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225515.353:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225525.860:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9581899: LauncherMain.cpp(104)] Initiated models [0116/225525.861:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9592226: LauncherController.cpp(435)] Constructing launcher controller with workDir: C:\...\.minecraft, isActive: 0 [0116/225525.861:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9819604: LauncherAppRenderer.cpp(172)] Javascript bridge extended in OnWebKitInitialized. [0116/225526.215:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=3 [0116/225526.238:INFO:LauncherAppRenderer.cpp(69)] OnBrowserDestroyed: id=3 [0116/225526.387:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=3 [0116/225538.615:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=1 [0116/225825.050:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=5 [0116/230007.904:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=6     "Latest" code [16jan.2022 23:00:09.457] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, Elverea, --version, 1.18.1-forge-39.0.36, --gameDir, C:\Users\Norge\AppData\Roaming\.minecraft, --assetsDir, C:\Users\Norge\AppData\Roaming\.minecraft\assets, --assetIndex, 1.18, --uuid, 31cc9858833c43488f09a460a739f964, --accessToken, ????????, --clientId, NzcyMWNmNWYtZGZhNS00YmY1LWFkMTgtMTljYjVhNzZhODM5, --xuid, 2535453675472907, --userType, msa, --versionType, release, --launchTarget, forgeclient, --fml.forgeVersion, 39.0.36, --fml.mcVersion, 1.18.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20211210.034407] [16jan.2022 23:00:09.462] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 9.0.7+91+master.8569cdf starting: java version 17.0.1 by Microsoft
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.