Jump to content

Error using discord rpc and forge


chickenfan
 Share

Recommended Posts

Hi, when I try and use discord rpc (https://github.com/Vatuu/discord-rpc) and forge 1.12.2 14.23.5.2768 I have a compilation error.

The Error:

> Task :compileJava FAILED
D:\Slover_Mod_For_SloverTeam\build\sources\main\java\SloverTeam\DiscordIntegration.java:4: error: package net.arikia.dev.drpc does not exist
import net.arikia.dev.drpc.DiscordEventHandlers;
                          ^
D:\Slover_Mod_For_SloverTeam\build\sources\main\java\SloverTeam\DiscordIntegration.java:5: error: package net.arikia.dev.drpc does not exist
import net.arikia.dev.drpc.DiscordRPC;
                          ^
D:\Slover_Mod_For_SloverTeam\build\sources\main\java\SloverTeam\DiscordIntegration.java:6: error: package net.arikia.dev.drpc does not exist
import net.arikia.dev.drpc.DiscordRichPresence;
                          ^
D:\Slover_Mod_For_SloverTeam\build\sources\main\java\SloverTeam\DiscordIntegration.java:7: error: package net.arikia.dev.drpc does not exist
import net.arikia.dev.drpc.DiscordUser;
                          ^
D:\Slover_Mod_For_SloverTeam\build\sources\main\java\SloverTeam\DiscordIntegration.java:8: error: package net.arikia.dev.drpc.callbacks does not exist
import net.arikia.dev.drpc.callbacks.ReadyCallback;
                                    ^
5 errors

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.

 

Link to comment
Share on other sites

25 minutes ago, DeDxYk594 said:

1.12.2 is outdated version now. 

Error messages says you that some packages does not exists. It may be caused by a lack of some mods. Try to repair files.

Wdym by that, I understand that 1.12.2 is outdated but wdym by repair files and there may be a lack of mods

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.