• Recently Browsing

    No registered users viewing this page.

  • Posts

    • You need to use the SRG name, this won't work outside the development environment.   What...? What... Just... what is this?   This will crash on a server, as the server has no idea about the Minecraft class.   Client-only events must be in a separate @EventBusSubscriber class with Dist.CLIENT passed to @EventBusSubscriber.
    • I cant understand how do I need to find error with that. I runned debugger for mdk and error was creating resource named "DUMMY" so I think it wasnt my mod that causes error. Also I checked my resources and I dont have non ascii characters
    • I believe this new version covers everything you said. I used an attached player capability for the boolean. private static final Field field = ObfuscationReflectionHelper.findField(Minecraft.class, "rightClickDelayTimer"); @SubscribeEvent public void onClientTickEvent(TickEvent.ClientTickEvent event) throws IllegalAccessException { if(event.phase == TickEvent.Phase.START) { try { if(CustomCapabilities.getPlayer(Minecraft.getInstance().player).getVariable("string", "HasBrokenMyBlock").equals("true")){ field.setInt(Minecraft.getInstance(), 0); CustomCapabilities.getPlayer(Minecraft.getInstance().player).setVariable("HasBrokenMyBlock", "false"); } } catch (NullPointerException e) {} } } @SubscribeEvent public void farmBlock(PlayerInteractEvent.RightClickBlock event) { if(event.getPlayer() == Minecraft.getInstance().player){ if(event.getPlayer().getHeldItem(event.getHand()).getItem().equals(Items.SHEARS) && event.getWorld().getBlockState(event.getPos()).equals(RegistryHandler.MY_BLOCK.get().getDefaultState())){ CustomCapabilities.getPlayer(event.getPlayer()).setVariable("HasBrokenMyBlock", "true"); } } }   Everthing works, but a server instance isn't running because it doesn't like the ClientTickEvent: "Attempted to load class net/minecraft/client/entity/player/ClientPlayerEntity for invalid dist DEDICATED_SERVER"   Tried to use regular TickEvent and it gave me the same error.
    • Hello. I have a problem with the newest forge (32.0.57). The Problem I encounterd in different worlds, which were created in 1.16.1. I cannot repair two used Pickaxes (or tool/weapon) in the crafting field or grindstone or anvil. They are not enchanted! When these two tools/weapons are completly identical (same points of use) I get two stacked tools/weapons with the same amount of use. If the use is different it doesn't even display an output. The only mod I use is the "Xaeros_Minimap_20.15.3_Forge_1.16.1".
    • Read every part of this sentence. Every word is important and tells you exactly what the issue is.
  • Topics

  • Who's Online (See full list)