Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Need help on OSX modded server (allocating more RAM)


Recommended Posts

Hi ! I hope I'm posting in the right place !

I'm running a forge modded server to play with a bunch of friends and encountered this issue today while trying to allocate more RAM.

I created a script to launch the server wwith the RAM arguments. While the server runs fine if I double click the jar file (mods loading, can join, just short on RAM), if I run the server from the script, with or without the arguments, or even if I launch the server from the Terminal, some mods won't load properly and the server will eventually crash.

I'm struggling to understand why double click execution would work and not Terminal exec.

The two same mods are always incriminated, but they run fine if I double-click-launch.

Hope you can help me !

additionnal info :

The script :


cd "$(dirname "$0")"

exec java -Xms2G -Xmx2G -jar forge-1.15.2-31.2.0.jar


The crash report :



---- Minecraft Crash Report ----

// But it works on my machine.

Time: 6/1/20, 10:41 PM

Description: Exception in server tick loop

net.minecraftforge.fml.LoadingFailedException: Loading errors encountered: [

Nethercraft (nethercraft) has failed to load correctly


Guard Villagers (guardvillagers) has failed to load correctly

§7java.lang.IllegalAccessException: Can not set static final net.minecraft.world.gen.feature.jigsaw.JigsawPatternRegistry field net.minecraft.world.gen.feature.jigsaw.JigsawManager.field_214891_a to tallestegg.guardvillagers.GuardSpawner


at net.minecraftforge.fml.ModLoader.dispatchAndHandleError(ModLoader.java:218) ~[?:?] {re:classloading}

at net.minecraftforge.fml.ModLoader.gatherAndInitializeMods(ModLoader.java:200) ~[?:?] {re:classloading}

at net.minecraftforge.fml.server.ServerModLoader.begin(ServerModLoader.java:45) ~[?:?] {re:classloading}

at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:122) ~[?:?] {re:classloading,pl:accesstransformer:B}

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:613) [?:?] {re:classloading,pl:accesstransformer:B,pl:runtimedistcleaner:A}

at java.lang.Thread.run(Thread.java:835) [?:?] {}

A detailed walkthrough of the error, its code path and all known details is as follows:


-- System Details --


Minecraft Version: 1.15.2

Minecraft Version ID: 1.15.2

Operating System: Mac OS X (x86_64) version 10.14.6

Java Version: 14.0.1, AdoptOpenJDK

Java VM Version: Eclipse OpenJ9 VM (JRE 14 Mac OS X amd64-64-Bit Compressed References 20200427_53 (JIT enabled, AOT enabled)

OpenJ9 - 05fa2d361

OMR - d4365f371

JCL - 5757187cae based on jdk-14.0.1+7), Eclipse OpenJ9

Memory: 130853072 bytes (124 MB) / 620429312 bytes (591 MB) up to 2147483648 bytes (2048 MB)

CPUs: 6

JVM Flags: 3 total; -Xoptionsfile=/Library/Java/JavaVirtualMachines/adoptopenjdk-14-openj9.jdk/Contents/Home/lib/options.default -Xlockword:mode=default,noLockword=java/lang/String,noLockword=java/util/MapEntry,noLockword=java/util/HashMap$Entry,noLockword=org/apache/harmony/luni/util/ModifiedMap$Entry,noLockword=java/util/Hashtable$Entry,noLockword=java/lang/invoke/MethodType,noLockword=java/lang/invoke/MethodHandle,noLockword=java/lang/invoke/CollectHandle,noLockword=java/lang/invoke/ConstructorHandle,noLockword=java/lang/invoke/ConvertHandle,noLockword=java/lang/invoke/ArgumentConversionHandle,noLockword=java/lang/invoke/AsTypeHandle,noLockword=java/lang/invoke/ExplicitCastHandle,noLockword=java/lang/invoke/FilterReturnHandle,noLockword=java/lang/invoke/DirectHandle,noLockword=java/lang/invoke/ReceiverBoundHandle,noLockword=java/lang/invoke/DynamicInvokerHandle,noLockword=java/lang/invoke/FieldHandle,noLockword=java/lang/invoke/FieldGetterHandle,noLockword=java/lang/invoke/FieldSetterHandle,noLockword=java/lang/invoke/StaticFieldGetterHandle,noLockword=java/lang/invoke/StaticFieldSetterHandle,noLockword=java/lang/invoke/IndirectHandle,noLockword=java/lang/invoke/InterfaceHandle,noLockword=java/lang/invoke/VirtualHandle,noLockword=java/lang/invoke/PrimitiveHandle,noLockword=java/lang/invoke/InvokeExactHandle,noLockword=java/lang/invoke/InvokeGenericHandle,noLockword=java/lang/invoke/VarargsCollectorHandle,noLockword=java/lang/invoke/ThunkTuple -Xjcl:jclse29

ModLauncher: 5.1.0+69+master.79f13f7

ModLauncher launch target: fmlserver

ModLauncher naming: srg

ModLauncher services:

/eventbus-2.2.0-service.jar eventbus PLUGINSERVICE /forge-1.15.2-31.2.0.jar object\_holder\_definalize PLUGINSERVICE /forge-1.15.2-31.2.0.jar runtime\_enum\_extender PLUGINSERVICE /forge-1.15.2-31.2.0.jar capability\_inject\_definalize PLUGINSERVICE /accesstransformers-2.1.1-shadowed.jar accesstransformer PLUGINSERVICE /forge-1.15.2-31.2.0.jar runtimedistcleaner PLUGINSERVICE /forge-1.15.2-31.2.0.jar fml TRANSFORMATIONSERVICE /MixinBootstrap-1.0.3.jar mixinbootstrap TRANSFORMATIONSERVICE /MixinBootstrap-1.0.3.jar mixin PLUGINSERVICE /MixinBootstrap-1.0.3.jar mixinbootstrap PLUGINSERVICE

FML: 31.2

Forge: net.minecraftforge:31.2.0

FML Language Providers:

javafml@31.2 minecraft@1 kotlinfml@1.5.1

Mod List:

glasscutter-1.0.1-1.15.2.jar Glasscutter {glasscutter@1.0.1 CREATE\_REGISTRIES} Craft\_and\_Hunt\_V1.1.0\_MC\_1.15.2.jar Craft and Hunt {craftandhunt@0.9 CREATE\_REGISTRIES} BETA+-+Camels+Mod+0.8.0+\[1.15.2\].jar Camel Mod {camels@0.8.0 CREATE\_REGISTRIES} Ma-Enchants-1.15.2-3.1.0.jar Ma Enchants {ma-enchants@1.15.2-3.1.0 CREATE\_REGISTRIES} Torch-Slabs-Mod-1.15.2.jar Torch Slab Mod {torchslabmod@1.4.0 CREATE\_REGISTRIES} HarvestCraft-Mod-Trees-1.15.2.jar Pam's HarvestCraft 2 Fruit Trees {pamhc2trees@version CREATE\_REGISTRIES} nethercraft-1.15.2-1.0.8.jar Nethercraft {nethercraft@1.0.8 ERROR} mining-helmet-1.15.2-1.0.8.jar Mining Helmet {mining\_helmet@1.0.8 CREATE\_REGISTRIES} lithium-mc1.15.2-forge-0.4.6-rc3-mod.jar Lithium {lithium@0.4.6-rc3 CREATE\_REGISTRIES} DoggyTalents-1.15.2- Doggy Talents {doggytalents@ CREATE\_REGISTRIES} Abnormals-Core-1.15.2-v1.0.5.jar Abnormals Core {abnormals\_core@1.0.5 CREATE\_REGISTRIES} Buzzier-Bees-1.15.2-v1.5.0.jar Buzzier Bees {buzzierbees@v1.5.0 CREATE\_REGISTRIES} Upgrade-Aquatic-1.15.2-v1.6.1.jar Upgrade Aquatic {upgrade\_aquatic@1.6.1 CREATE\_REGISTRIES} Clumps-5.0.2.jar Clumps {clumps@5.0.2 CREATE\_REGISTRIES} Cooking-for-Blockheads-Mod-1.15.2.jar Cooking for Blockheads {cookingforblockheads@8.0.1 CREATE\_REGISTRIES} Placebo-1.15.2-3.0.2.jar Placebo {placebo@3.0.2 CREATE\_REGISTRIES} Comforts-Mod-1.15.2.jar Comforts {comforts@FORGE-1.15.2-2.0 CREATE\_REGISTRIES} good-nights-sleep-1.15.2-1.0.3.jar Good Night's Sleep {goodnightsleep@1.0.3 CREATE\_REGISTRIES} SereneSeasons-1.15.2- Serene Seasons {sereneseasons@1.15.2- CREATE\_REGISTRIES} decorative\_blocks-6d.jar Decorative Blocks {decorative\_blocks@1.6 CREATE\_REGISTRIES} Nomadic-Tents-Mod-1.15.2.jar Nomadic Tents {nomadictents@11.0.0-beta CREATE\_REGISTRIES} betteranimalsplus-1.15.2- Better Animals Plus {betteranimalsplus@ CREATE\_REGISTRIES} Bookshelf-1.15.2-5.6.38.jar Bookshelf {bookshelf@5.6.38 CREATE\_REGISTRIES} BotanyPots-1.15.2-2.0.17.jar BotanyPots {botanypots@2.0.17 CREATE\_REGISTRIES} The-Endergetic-Expansion-1.15.2-v1.2.8.jar The Endergetic Expansion {endergetic@1.2.8 CREATE\_REGISTRIES} guardvillagers-1.15.2-1.0.6.jar Guard Villagers {guardvillagers@1.0.6 ERROR} bottleyourxp\_1.15-1.2.jar Bottle Your Xp {bottleyourxp@1.2 CREATE\_REGISTRIES} ForgivingVoid\_1.15.1-4.0.0.jar Forgiving Void {forgivingvoid@4.0.0 CREATE\_REGISTRIES} mcw-doors-1.0.0-mc1.15.2.jar Macaw's Doors {mcwdoors@1.0.0 CREATE\_REGISTRIES} Bedspreads-Mod-1.15.2.jar Bedspreads {bedspreads@FORGE-1.15.2-3.0 CREATE\_REGISTRIES} beyond\_the\_nether\_wastes\_v\_1.0.0.jar Beyond The Nether Wastes {btnw@1.0.0 CREATE\_REGISTRIES} forge-1.15.2-31.2.0-universal.jar Forge {forge@31.2.0 CREATE\_REGISTRIES} Waddles-1.15.2-0.8.6.jar Waddles {waddles@1.15.2-0.8.6 CREATE\_REGISTRIES} shetiphiancore-1.15-3.7.1.jar ShetiPhian-Core {shetiphiancore@3.7.1 CREATE\_REGISTRIES} xercamusic-1.15.2-2.1.jar Xerca's Music Maker Mod {xercamusic@1.15.2-2.1 CREATE\_REGISTRIES} iiwam-1.15.2-1.0.jar If I Worked At Mojang {iiwam@1.0.0 CREATE\_REGISTRIES} extradiscs-1.0.0-forge1.15.2+build.1.jar ExtraDiscs {extradiscs@1.0.0-forge1.15.2+build.1 CREATE\_REGISTRIES} forge-1.15.2-31.2.0-server.jar Minecraft {minecraft@1.15.2 CREATE\_REGISTRIES} mcw-bridges-1.0.4fix-mc1.15.2.jar Macaw's Bridges {mcwbridges@1.0.4 CREATE\_REGISTRIES} endportrec\_1.15-1.1.jar End Portal Recipe {endportrec@1.1 CREATE\_REGISTRIES} projectvibrantjourneys-1.15.2-2.0.1.jar Project: Vibrant Journeys {projectvibrantjourneys@1.15.2-2.0.1 CREATE\_REGISTRIES} phosphor-forge-mc1.15.2-0.5.2+build.4.jar Phosphor {phosphor@0.5.2+build.4 CREATE\_REGISTRIES} HarvestCraft-Mod-Crops-1.15.2.jar Pam's HarvestCraft 2 Crops {pamhc2crops@version CREATE\_REGISTRIES} astikorcarts-1.0.1-1.15.2.jar AstikorCarts {astikorcarts@1.0.1 CREATE\_REGISTRIES} xercamod-1.15.2-2.5.jar Xerca Mod {xercamod@1.15.2-2.5 CREATE\_REGISTRIES} Bountiful-1.15.2-3.1.0.jar Bountiful {bountiful@1.15.2-3.1.0 CREATE\_REGISTRIES} gaiadimension-1.15.2-1.2.1.jar The Gaia Dimension {gaiadimension@1.2.1 CREATE\_REGISTRIES} Patchouli-1.15.2-1.2-33.jar Patchouli {patchouli@1.15.2-1.2-33 CREATE\_REGISTRIES} Mantle-1.15.2-1.5.15.jar Mantle {mantle@1.5.15 CREATE\_REGISTRIES} Inspirations-1.15.2-1.1.0.jar Inspirations {inspirations@1.15.2-1.1.0 CREATE\_REGISTRIES} corail\_woodcutter-1.1.3-1.15.2.jar Corail Woodcutter {corail\_woodcutter@1.1.3 CREATE\_REGISTRIES} rediscovered-1.15.2-0.0.1.jar Rediscovered {rediscovered@0.0.1 CREATE\_REGISTRIES} HarvestCraft-Mod-Food-Core-1.15.2.jar Pam's HarvestCraft 2 Food Core {pamhc2foodcore@version CREATE\_REGISTRIES} multibeds-1.15-1.6.0.jar Multi-Beds {multibeds@1.6.0 CREATE\_REGISTRIES} AutoRegLib-1.5-40.jar AutoRegLib {autoreglib@1.5-40 CREATE\_REGISTRIES} Quark-r2.1-239.jar Quark {quark@r2.1-239 CREATE\_REGISTRIES} extragolems-10.2.0.jar Extra Golems {golems@10.2.0 CREATE\_REGISTRIES} MrCrayfishs-Backpacked-Mod-1.15.2.jar Backpacked {backpacked@1.4.1 CREATE\_REGISTRIES} EndReborn+\[0.5.3\].jar End: Reborn {endreborn@0.5.3 CREATE\_REGISTRIES} xercapaint-1.15.2-2.1.jar Joy of Painting {xercapaint@1.15.2-2.1 CREATE\_REGISTRIES} themidnight-0.5.7-3.jar The Midnight {midnight@0.5.7-3 CREATE\_REGISTRIES} libnonymous-1.15.2- Libnonymous {libnonymous@ CREATE\_REGISTRIES} BonsaiTrees- Bonsai Trees 2 {bonsaitrees2@ CREATE\_REGISTRIES} MrCrayfishs-Furniture-Mod-1.15.2.jar MrCrayfish's Furniture Mod {cfm@7.0.0-pre16 CREATE\_REGISTRIES} Aquaculture-1.15.2-2.0.14.jar Aquaculture 2 {aquaculture@1.15.2-2.0.14 CREATE\_REGISTRIES} the\_bumblezone-1.15.2-1.3.2.jar The Bumblezone {the\_bumblezone@1.15.2-1.3.2 CREATE\_REGISTRIES} XL-Food-Mod-1.15.2-2.2.2.jar XL Food Mod {xlfoodmod@2.2.2 CREATE\_REGISTRIES} Charm-1.15.2-1.5.7.jar Charm {charm@1.15.2-1.5.7 CREATE\_REGISTRIES} Strange-1.15.2-1.0.0-beta.3.jar Strange {strange@1.15.2-1.0.0-beta.3 CREATE\_REGISTRIES} incubation-1.0.4-1.15.2.jar Incubation {incubation@1.0.4 CREATE\_REGISTRIES} TofuCraftReload-1.15.2- TofuCraftReload {tofucraft@ CREATE\_REGISTRIES} Bambootiful-Mod-1.14.4.jar Bambootiful {bambootiful@1.1.3 CREATE\_REGISTRIES} farlanders-1.15.2-1.1.2.jar The Farlanders {farlanders@1.1.2 CREATE\_REGISTRIES}

Pulsar/inspirations loaded Pulses:

\- InspirationsShared (Enabled/Forced) \- InspirationsBuilding (Enabled/Not Forced) \- InspirationsUtility (Enabled/Not Forced) \- InspirationsTools (Enabled/Not Forced) \- InspirationsTweaks (Enabled/Not Forced)

Data Packs:

Is Modded: Definitely; Server brand changed to 'forge'

Type: Dedicated Server (map_server.txt)



Edited by MrDonoyo
Link to comment
Share on other sites

17 minutes ago, diesieben07 said:

Looks like a problem with "Nethercraft". Make sure it is up to date, otherwise report this to the author.

Yes, but if I launch the server by double clicking on the jar file, it works, Nethercraft runs fine also. What is the causing the issue then ?

Edited by MrDonoyo
Link to comment
Share on other sites

You should be using Java 8 HotSpot, Java 8 because it's what mods should be targeting and HotSpot because it's what some of Forge's black magic is designed for.

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.


As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.


For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.


Logs (Most issues require logs to diagnose):


Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.


What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...


...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension


Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.


Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.






or alternately, 


Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft


Server Not Starting:


If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.


Reporting Illegal/Inappropriate Adfocus Ads:


Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.


Posting your mod as a GitHub Repo:


When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.


  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]


Link to comment
Share on other sites

On 6/1/2020 at 11:48 PM, DaemonUmbra said:

You should be using Java 8 HotSpot, Java 8 because it's what mods should be targeting and HotSpot because it's what some of Forge's black magic is designed for.

Thank you ! Did the trick apparently !


22 hours ago, CAPITANKW said:

i use this scrip


cd "$(dirname "$0")"

exec java -Xms1G -Xmx1G -jar forge-1.15.2-31.2.0.jar  and only use 200 mb of ram , my server its to laggy 

could someone help me ?

I ran through the same issue, it seems uninstalling java and reinstalling the proper version worked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.