Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.14.4] missing id from the world Fixed minecraft:item id mismatch


frakier
 Share

Recommended Posts

In the log file I see stuff like this...

Registry Block: Found a missing id from the world minecraft:random_block
Registry Block: Fixed minecraft:block id mismatch mymod:random_block
Fixed minecraft:item id mismatch mymod:monster_hide
Fixed minecraft:sound_event id mismatch mymod:mysound.armor

Is this just part of the process/reporting or am I somehow causing this, everything works as expected otherwise even the items/blocks/sounds that are being "fixed"
 

Link to comment
Share on other sites

When I get this type of error it's normally a sign that I've changed my code (eg added a new item) and re-used an old save.

 

As a rule I always generate a new save after making significant code changes, I've been bitten a couple of times by weird behaviour that looks like a bug in my code but was actually just because I was re-using an old save.

 

-TGG

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.