Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

'Missing Model for variant' on a block that has no variants.


Arkevorkhat
 Share

Recommended Posts

(Code repository to be referenced: https://github.com/codycoolwaffle/Steamworks )
I've created a simple block (following the docs, file src/main/java/waffletopia/steamworks/common/block/ore.java)
whenever I launch the development client, I get a pair of warnings:
 

[00:59:48] [Server-Worker-4/WARN] [minecraft/ModelBakery]: Exception loading blockstate definition: 'steamworks:blockstates/ore_zinc.json' missing model for variant: 'steamworks:ore_zinc#'
[00:59:48] [Server-Worker-4/WARN] [minecraft/ModelBakery]: Exception loading blockstate definition: 'steamworks:blockstates/ore_zinc.json' in resourcepack: 'Mod Resources': Neither 'variants' nor 'multipart' found


This would be fine, but my code doesn't define *any* variants, especially not one named #.
I get a java.io.FileNotFound exception instead if I don't include a blockstates/ore_zinc.json file, and even then, no texture appears on the block.

In case it's of any relevance, the BlockItem for the zinc ore block *does* successfully find and use the texture that I supplied for it.

 

Any thoughts?

Link to comment
Share on other sites

  • Do not create blocks, items or any registry entries in a static initializer. Use the proper registry events or DeferredRegister.
  • If your block doesn't have any variants it can't display anything. You need to specify the empty variant with a model, otherwise Minecraft has no idea how to render your block. Look at vanilla block states for simple blocks for examples.
  • Confused 1
Link to comment
Share on other sites

OK, let's say you were in a position where you *weren't* more inclined to chastise me for code style than actually do anything to help:
where, pray tell, would I be expected to be able to find a copy of the vanilla minecraft code for defining blocks, when the entire reason that forge exists is that minecraft code is obfuscated to the point of being impossible to work with?

Link to comment
Share on other sites

1 minute ago, Arkevorkhat said:

OK, let's say you were in a position where you *weren't* more inclined to chastise me for code style than actually do anything to help:

It's not about code style. I was pointing out a problem with your code that will cause you problems don't the line. No "chastising" of you, your code or your code-style has taken place.

 

2 minutes ago, Arkevorkhat said:

where, pray tell, would I be expected to be able to find a copy of the vanilla minecraft code for defining blocks

It's not code, it's JSON files. You find them by using the "find file" function of your IDE. In IntelliJ that would be Ctrl-Shift-N. I don't know about Eclipse because i don't use it, but I am sure it has similar functionality.

 

5 minutes ago, Arkevorkhat said:

when the entire reason that forge exists is that minecraft code is obfuscated to the point of being impossible to work with?

That is not the reason Forge exists. The reason Forge exists is that if everyone were to just modify the class files ("jarmodding") like it used to be in the very old days mods would be incompatible with each other all the time.

And in fact Forge uses MCP's data to deobfuscate Minecraft code to the point of it being quite usable. Not pretty, but usable.

Link to comment
Share on other sites

You should post your entire debug.log, and not cherry pick it as there can be things in there that could be related that you are omitting without realizing it.

 

Also your textures/blocks folder should be named block instead of blocks (I believe this was one of the 1.13 rewrite changes). That could be why you were getting a missing texture at on point like you mentioned.

 

*edit: and in your blockstate, you need to specify at least 1 state for the block, if there's no variants use empty "", and it must specify a model for that state, and you have empty curly braces.

 

The vanilla blockstates, if you wish to reference them, are in the client-extras jar in your IDEs referenced libraries.

Edited by Ugdhar
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • @RideableEntitiesModElements.ModElement.Tag public class BabytigerEntity extends RideableEntitiesModElements.ModElement { public static EntityType entity = (EntityType.Builder.<CustomEntity>create(CustomEntity::new, EntityClassification.MONSTER) .setShouldReceiveVelocityUpdates(true).setTrackingRange(64).setUpdateInterval(3).setCustomClientFactory(CustomEntity::new) .size(0.6f, 1.8f)).build("babytiger").setRegistryName("babytiger"); public BabytigerEntity(RideableEntitiesModElements instance) { super(instance, 4); FMLJavaModLoadingContext.get().getModEventBus().register(new BabytigerRenderer.ModelRegisterHandler()); FMLJavaModLoadingContext.get().getModEventBus().register(new EntityAttributesRegisterHandler()); MinecraftForge.EVENT_BUS.register(this); } @Override public void initElements() { elements.entities.add(() -> entity); elements.items .add(() -> new SpawnEggItem(entity, -1, -1, new Item.Properties().group(ItemGroup.MISC)).setRegistryName("babytiger_spawn_egg")); } @SubscribeEvent public void addFeatureToBiomes(BiomeLoadingEvent event) { event.getSpawns().getSpawner(EntityClassification.MONSTER).add(new MobSpawnInfo.Spawners(entity, 20, 4, 4)); } @Override public void init(FMLCommonSetupEvent event) { EntitySpawnPlacementRegistry.register(entity, EntitySpawnPlacementRegistry.PlacementType.ON_GROUND, Heightmap.Type.MOTION_BLOCKING_NO_LEAVES, MonsterEntity::canMonsterSpawn); } private static class EntityAttributesRegisterHandler { @SubscribeEvent public void onEntityAttributeCreation(EntityAttributeCreationEvent event) { AttributeModifierMap.MutableAttribute ammma = MobEntity.func_233666_p_(); ammma = ammma.createMutableAttribute(Attributes.MOVEMENT_SPEED, 0.8); ammma = ammma.createMutableAttribute(Attributes.MAX_HEALTH, 10); ammma = ammma.createMutableAttribute(Attributes.ARMOR, 0); ammma = ammma.createMutableAttribute(Attributes.ATTACK_DAMAGE, 3); event.put(entity, ammma.create()); } } public static class CustomEntity extends CreatureEntity { public CustomEntity(FMLPlayMessages.SpawnEntity packet, World world) { this(entity, world); } public CustomEntity(EntityType<CustomEntity> type, World world) { super(type, world); experienceValue = 0; setNoAI(false); } @Override public IPacket<?> createSpawnPacket() { return NetworkHooks.getEntitySpawningPacket(this); } @Override protected void registerGoals() { super.registerGoals(); this.goalSelector.addGoal(1, new MeleeAttackGoal(this, 1.2, false)); this.goalSelector.addGoal(2, new RandomWalkingGoal(this, 1)); this.targetSelector.addGoal(3, new HurtByTargetGoal(this)); this.goalSelector.addGoal(4, new LookRandomlyGoal(this)); this.goalSelector.addGoal(5, new SwimGoal(this)); } @Override public CreatureAttribute getCreatureAttribute() { return CreatureAttribute.UNDEFINED; } @Override public net.minecraft.util.SoundEvent getHurtSound(DamageSource ds) { return (net.minecraft.util.SoundEvent) ForgeRegistries.SOUND_EVENTS.getValue(new ResourceLocation("entity.generic.hurt")); } @Override public net.minecraft.util.SoundEvent getDeathSound() { return (net.minecraft.util.SoundEvent) ForgeRegistries.SOUND_EVENTS.getValue(new ResourceLocation("entity.generic.death")); } @Override public ActionResultType func_230254_b_(PlayerEntity sourceentity, Hand hand) { ItemStack itemstack = sourceentity.getHeldItem(hand); ActionResultType retval = ActionResultType.func_233537_a_(this.world.isRemote()); super.func_230254_b_(sourceentity, hand); sourceentity.startRiding(this); return retval; } @Override public void travel(Vector3d dir) { Entity entity = this.getPassengers().isEmpty() ? null : (Entity) this.getPassengers().get(0); if (this.isBeingRidden()) { this.rotationYaw = entity.rotationYaw; this.prevRotationYaw = this.rotationYaw; this.rotationPitch = entity.rotationPitch * 0.5F; this.setRotation(this.rotationYaw, this.rotationPitch); this.jumpMovementFactor = this.getAIMoveSpeed() * 0.15F; this.renderYawOffset = entity.rotationYaw; this.rotationYawHead = entity.rotationYaw; this.stepHeight = 1.0F; if (entity instanceof LivingEntity) { this.setAIMoveSpeed((float) this.getAttributeValue(Attributes.MOVEMENT_SPEED)); float forward = ((LivingEntity) entity).moveForward; float strafe = ((LivingEntity) entity).moveStrafing; super.travel(new Vector3d(strafe, 0, forward)); } this.prevLimbSwingAmount = this.limbSwingAmount; double d1 = this.getPosX() - this.prevPosX; double d0 = this.getPosZ() - this.prevPosZ; float f1 = MathHelper.sqrt(d1 * d1 + d0 * d0) * 4.0F; if (f1 > 1.0F) f1 = 1.0F; this.limbSwingAmount += (f1 - this.limbSwingAmount) * 0.4F; this.limbSwing += this.limbSwingAmount; return; } this.stepHeight = 0.5F; this.jumpMovementFactor = 0.02F; super.travel(dir); } } } ok thanks and for the people that want to copy paste here is the code
    • I did download the latest forge-1.18-38.0.6-installer and installed it correctly into the right place. Also downloaded  38.0.5 to test (didn't work) and downloaded 38.0.0 None of those worked.
    • Unknown module securejarhandler implies that some libraries were missed during the installation. I suggest you redownload the latest installer and run it again.
    • Forge Version: 38.0.6 Minecraft Version: 1.18 Downloads: Changelog: (Direct) Installer: (AdFocus) (Direct) MDK: (AdFocus) (Direct) However, as this is the start of a new version, it is recommended that you check the Downloads Page and use the latest version to receive any bug fixes. Intro: 1.17 was a stepping stone, and 1.18 is the real target. The culmination of the Caves & Cliffs update, with few real code changes from 1.17 except those required to plug in the new biome system. This is our new Latest version. As we had some time before the release, we handled some refactors beforehand. Those will be listed here. Changelog: Refactors (not comprehensive): 99% of the fmllegacy package. Most classes were simply moved from x.y.fmllegacy.z to x.y.z. All instances of Gui -> Screen (GuiOpenEvent -> ScreenOpenEvent, for example) GuiScreenEvent -> ScreenEvent, GuiOverlayDebugForge -> ForgeDebugScreenOverlay All instances of GameMode -> GameType (ClientPlayerChangeGameModeEvent -> ClientPlayerChangedGameTypeEvent, for example) All instances of MatrixStack -> PoseStack (DrawSelectionEvent.matrix -> DrawSelectionEvent.poseStack, for example All instances of KeyBinding -> KeyMapping (ClickInputEvent.keyBinding -> ClickInputEvent.keyMapping, for example All instances of World -> Level All instances of WorldType -> WorldPreset (ForgeHooksClient.getDefaultWorldType -> ForgeHooksClient.getDefaultWorldPreset, for example All instances of NBT -> Tag (BlockSnapshot.getNbt -> BlockSnapshot.getTag, for example) All instances of Container -> Menu (IForgeContainerType -> IForgeMenuType, for example) PlaySoundEvent.sound -> PlaySoundEvent.originalSound PlaySoundEvent.result -> PlaySoundEvent.sound SoundEvent.manager -> SoundEvent.engine SoundEvent.SoundSourceEvent.source -> SoundEvent.SoundSourceEvent.channel FOVUpdateEvent -> FOVModifierEvent EntityViewRenderEvent.FOVModiier -> EntityViewRenderEvent.FieldOfView InputUpdateEvent -> MovementInputUpdateEvent InitScreenEvent.{...Widget...} -> {...Listener...} ForgeItemTagsProvider.func_240521_a_Colored -> copyColored MobSpawnInfoBuilder -> MobSpawnSettingBuilder BasicTrade -> BasicItemListing ModelLoader -> ForgeModelBakery ForgeWorldTypeScreens -> ForgeWorldPresetEditors StackList -> MultItemValue Removals: Entire Animation API IForgeTextureAtlasSprite IForgeItem.{showDurabiityBar, getDurabilityForDisplay, getRGBDurabilityForDisplay} ForgeHooksClient.refreshResources ModelBuilder.gui3d BlockInfo.{updateShift, getShx, getShy, getShz} CapabilityInject CapabilityManager.register ConditionalAdvancement.processConditions IForgeItem.isShield IForgeStructureFeature.{getDefaultSpawnList, getDefaultCreatureSpawnList} Forge's Constants class VanillaResourceType ForgeHooksClient.worldRenderPass (+ accessor) ForgeHooksClient.{preDraw, postDraw, getColorIndex} ScrollPanel.drawBackground Screen.{RenderToolTip, RenderComponentToolTip} ResourceManager.getResourceType LootPool.bonusRolls ForgeConfig - selectiveResourceReload PotionEvent.PotionAddedEvent ClientHooks ModFileResourcePack ResourcePackLoader.getResourcePackFor ResourcePackLoader.IPackInfoFinder ServerLifecycleHooks.buildPackFinder IResourceType ReloadRequirements CommandSetDimension
    • This is the error that I'm getting. WARNING: Unknown module: cpw.mods.securejarhandler specified to --add-exports WARNING: Unknown module: cpw.mods.securejarhandler specified to --add-opens Exception in thread "main" java.lang.module.FindException: Module org.objectweb.asm.util not found, required by org.openjdk.nashorn at java.base/java.lang.module.Resolver.findFail(Resolver.java:893) at java.base/java.lang.module.Resolver.resolve(Resolver.java:192) at java.base/java.lang.module.Resolver.resolve(Resolver.java:141) at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:492) at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:298) at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:83)   Tried various java versions,   8 and 16 to no avail. even tried bellsoft liberica full jre  and openjre   No clue what is going on and why there are such problems with Java now, seems like Oracle took their ball and wants to go home with the Java project. So many issues with various versions of it.  Any advice? Thanks,.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.