Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Advancements completing no matter what dimension I go to.


Cinderous
 Share

Recommended Posts

So, Ive been stuck on this for a few days and cannot figure out why this is happening. I have a tiered dimension system where you get to one dimension from the other. The advancements are in order. Whenever I change to any dimension, all my advancements that have a dimension change condition are completed. Ive rewritten it dozens of times, checked over other advancements for syntax issues, and I honestly cant figure it out. Ive even tried adding a biome requirement on top of it, but they still fire off. Here a screenshot of it happening https://i.imgur.com/Bve4DWD.gifv

 

Im lost with why this is happening. Here is an example of one of my advancements regarding the dimension Hyperlane. Each of the the 3 advancements specifically have a condition for the name of the dimension. It makes no sense why other dimensions are triggering them.

 

{
  "parent": "hyperl:hyperlane_gel_residue",
  "display": {
    "icon": {
      "item": "hyperl:hyperlane_staff"
    },
    "title": {
      "translate": "advancements.hyperl.hyperlane_staff.title"
    },
    "description": {
      "translate": "advancements.hyperl.hyperlane_staff.description"
    },
    "frame": "challenge",
    "show_toast": true,
    "announce_to_chat": true,
    "hidden": false
  },
  "criteria": {
    "entered_hyperlane": {
      "trigger": "minecraft:changed_dimension",
      "conditions": {
        "to": "hyperl:hyperlane"
      }
    }
  },
  "requirements": [
    [
      "entered_hyperlane"
    ]
  ]
}

 

 

To see the same looking files, here is my github for the advancements  https://github.com/cinderous/Hyperlane/tree/master/src/main/resources/data/hyperl/advancements

Edited by Cinderous
Link to comment
Share on other sites

27 minutes ago, Cinderous said:

hyperl:hyperlane

// ChangeDimensionTrigger.class, MC version 1.15.2, mappings 20200514-1.15.1, L23 (partial)
DimensionType.byName(new ResourceLocation(JSONUtils.getString(json, "from")))

// DimensionType.class,  MC version 1.15.2, mappings 20200514-1.15.1, L102-105
@Nullable
public static DimensionType byName(ResourceLocation nameIn) {
    return Registry.DIMENSION_TYPE.getOrDefault(nameIn);
}

Use the registry name that you used in your DeferredRegister: "hyperl:hyperlane_dim"

Edited by sciwhiz12
Link to comment
Share on other sites

This is the main class where I set that

 

public static final ResourceLocation HYPERLANE_DIM_TYPE = new ResourceLocation(MOD_ID, "hyperlane");

 

And the deferred registry part in my registry handler
 

public static final RegistryObject<ModDimension> HYPERLANE_DIM = MOD_DIMENSIONS.register("hyperlane_dim", () -> new HyperlaneModDimension());

 

 

Ive tried using either of these, hyperlane or hyperlane_dim in the condition. Same thing. No matter what dimension, it activates.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • no, the way he use it's the way to go
    • Minecraft 1.16 requires java 8-15, you currently using java 16, downgrade your java to 8-15 and the problem should be fixed.
    • Hi So Im trying to set up a Server for 1.16.4 now but when I go to launch it doesn't work, Im using the Life in the Village 2 server pack thats already pre-made but it still wont launch no matter what I try. If I can get some help that would be great thanks. D:\Modded Mc\LITV2-Serverpack-1.28a\LITV2-Serverpack-1.28a>java -Xmx4G -jar forge-1.16.5-36.2.4.jar nogui 2021-11-29 13:43:08,050 main WARN Advanced terminal features are not available in this environment [13:43:08] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.4, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui] [13:43:08] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.2 by Oracle Corporation Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x4de5031f) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x4de5031f at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41) at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95) at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41) at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55) at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708) at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52) at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47) at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62) at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55) at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63) at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60) at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) D:\Modded Mc\LITV2-Serverpack-1.28a\LITV2-Serverpack-1.28a>pause Press any key to continue . . .  
    • Still waiting on the issue.
    • Registering in static fields isn't ideal. You have a method that registers your deferred register to the event bus, right? leave your RegistryObject fields as non-final and empty, and set their reference in that method, right after registering the deferred register on the bus.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.