Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

(1.16.1) How to add another texture layer to chestplate


iSyriux
 Share

Recommended Posts

(here is the full code for reference)

// Made with Blockbench 3.6.3
// Exported for Minecraft version 1.15
// Paste this class into your mod and generate all required imports


public class custom_model extends BipedModel<LivingEntity> {
   private final ModelRenderer bipedHead;
   private final ModelRenderer bipedHeadwear;
   private final ModelRenderer bipedBody;
   private final ModelRenderer bipedRightLeg;
   private final ModelRenderer bipedLeftLeg;
   private final ModelRenderer bipedLeftArm;
   private final ModelRenderer bipedRightArm;

   public custom_model(float modelSize) {
      super(modelSize, 0.0F, 64, 40);

      ModelRenderer bipedBody = new ModelRenderer(this);
      bipedBody.setRotationPoint(0.0F, 0.0F, 0.0F);
      bipedBody.setTextureOffset(0, 32).addBox(-9.0F, 0.0F, -2.0F, 18.0F, 4.0F, 4.0F, 0.25F, false);

   }

   public void setRotationAngle(ModelRenderer modelRenderer, float x, float y, float z) {
      modelRenderer.rotateAngleX = x;
      modelRenderer.rotateAngleY = y;
      modelRenderer.rotateAngleZ = z;
   }
}
Link to comment
Share on other sites

2 minutes ago, iSyriux said:

BipedModel extended Living Entity, but when I return it it gives an error

That's probably because biped model doesn't extend living entity. You are also interpreting generics backwards. You need a class that is an instance of BipedModel, not the opposite way around.

 

Please take the time to learn java if you haven't already. It will definitely help when doing all this in the future.

Edited by ChampionAsh5357
  • Like 1
Link to comment
Share on other sites

8 minutes ago, iSyriux said:

Okay, so I traced the method back to pauldronarmouritem.java and found that 

image.png.a86f739a769b4522252b8ec5cdfdc49f.png

BipedModel extended Living Entity, but when I return it it gives an error

image.png.53a855e8670db8951b9981b4b6561e41.png

 

Jesus fucking christ.

image.png.d101b0348b203e7a82d78d60801c82ef.png

  • Like 1
  • Haha 1

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

<accidental double post>
 

 

Edited by Draco18s
  • Like 1

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

return LivingEntity;

1- You don't have to return LivingEntity! You have to return your custom_model class.

2- You have to return an instance of the class. Something like this:

return new custom_model(your constuctor argument);

I'm literally giving you the code, why can't you understand???

Edited by Danebi
  • Like 1
Link to comment
Share on other sites

@MostafaSabry55 I'm sorry if my questions seem rhetorical but I have a hard time understanding new concepts, even if you throw an answer at my face. Where is the place where I can learn java the fastest?

 

@ChampionAsh5357 What do you mean by caching the model?, also I put my constructor argument from the registhandler in the custom_model, however does not seem to function correctly.image.thumb.png.db75f3907efc6c4d268e37e065c3d35b.pngimage.png.4ad228cab6dfae1ddd3385a2faad8aa1.png

Link to comment
Share on other sites

Nope, the constructor of your model is this:

 public custom_model(float modelSize)

It requires a float value. Item#Properties is used by items and has nothing to do with the 3d model of your armor. Also what ChampionAsh5357 meant by caching is: right now, you are creating a new instance of your armor model in a function that gets called very often, which is very inefficient. You can just create an instance of your model once and for all in your client class (which is the place that rendering related objects belongs to)..and then returning that instance from getArmorModel. You can think it like that..Its like printing newspapers..normally you have a template newspaper and you can make thousands of prints with only that one template. Instead what you are doing is basically like making a new copy of the newspaper from scratch for every single print you have to do, Sorry if this example was stupid 😄, but i think it can help you understand better what is going on here

Check out the port of the BetterEnd fabric mod (WIP): https://www.curseforge.com/minecraft/mc-mods/betterend-forge-port

Link to comment
Share on other sites

3 hours ago, iSyriux said:

public custom_model(float modelSize) {

    super(modelSize, 0.0F, 64, 40);

    ModelRenderer bipedBody = new ModelRenderer(this);

    bipedBody.setRotationPoint(0.0F, 0.0F, 0.0F);

    bipedBody.setTextureOffset(0, 32).addBox(-9.0F, 0.0F, -2.0F, 18.0F, 4.0F, 4.0F, 0.25F, false);

}

The argument for the custom_model constuctor requires a float. Why are you giving it a Item.Properties?

Link to comment
Share on other sites

1) with:

public custom_model(float modelSize)
{
return null;
}

you are not creating a variable, its just the constructor for the custom_model class, which you already have in the model class. Its out of place in your PowerReinforcedArmourItem class, and wrong. Delete it.

 

2)

(float modelSize)

is the parameter requested by the constructor of your custom_model class, so when you are actually creating an object from the class, you need to pass in a value, not a parameter declaration...in this case you need to pass in a float, which is a number...for clarification:

custom_model(float modelSize) // This is a parameter declaration, you are specifying what kind of value your constructor will accept


custom_model(1.0f) // this is how a call to the constructor above will look like when creating a custom_model object, where 1.0f is the float value that will be passed to the contructor parameter "modelSize"

 

Edited by Beethoven92

Check out the port of the BetterEnd fabric mod (WIP): https://www.curseforge.com/minecraft/mc-mods/betterend-forge-port

Link to comment
Share on other sites

image.png.0917b01a9bc14106dd9d429806ac0c85.png

Okay, thank you for the assistance. I removed the constructor and replaced it with a value, however the custom_model was unknown to the class, so I added a private variable to the class that returned null, but it does not seem to function, even though my code now lacks errors.

image.png.e99afb4b23f6fb1bb0614b1fae61c8a8.pngimage.png.ec5b11d177506684964f8654b24da5af.png

Link to comment
Share on other sites

Again, you did not create an object of your custom_model class, with the last thing you added you now created a function which name is custom_model, which returns null. Then you are returning this function from getArmorModel, so that in the end getArmorModel returns null...this way your armor will never show up, so delete the last line of code you added and listen. To instantiate (create in other terms) a custom_model object you need to use new custom_model(a_float_value) , where a_float_value, as i said above, is a float number. Forget about caching at the moment...

  • Like 1

Check out the port of the BetterEnd fabric mod (WIP): https://www.curseforge.com/minecraft/mc-mods/betterend-forge-port

Link to comment
Share on other sites

Where do I put new custom_model(a_float_value), I'm sorry if you take this as a bad question, but I scrolled up and I saw that I needed to work on the return, which I had already did

image.png.86113c2bc58c9ba2097869ceedaec81f.png

The error asks me to create a new class, so should I do that? Sorry again, I analysed your answer fully a couple of times and I still can't see where you said to put 

16 minutes ago, Beethoven92 said:

new custom_model(a_float_value)

 

Link to comment
Share on other sites

The code above is now correct, even if it is terribly inefficient for the reasons i explained above. You already created a class named custom_model...you probably did not import it in the PowerReinforcedArmourItem file. When you hover with the mouse on the line that gives you the error it should also ask you if you want to import the package containing your custom_model class.

Check out the port of the BetterEnd fabric mod (WIP): https://www.curseforge.com/minecraft/mc-mods/betterend-forge-port

Link to comment
Share on other sites

5 hours ago, iSyriux said:

(here is the full code for reference)


// Made with Blockbench 3.6.3
// Exported for Minecraft version 1.15
// Paste this class into your mod and generate all required imports


public class custom_model extends BipedModel<LivingEntity> {
   private final ModelRenderer bipedHead;
   private final ModelRenderer bipedHeadwear;
   private final ModelRenderer bipedBody;
   private final ModelRenderer bipedRightLeg;
   private final ModelRenderer bipedLeftLeg;
   private final ModelRenderer bipedLeftArm;
   private final ModelRenderer bipedRightArm;

   public custom_model(float modelSize) {
      super(modelSize, 0.0F, 64, 40);

      ModelRenderer bipedBody = new ModelRenderer(this);
      bipedBody.setRotationPoint(0.0F, 0.0F, 0.0F);
      bipedBody.setTextureOffset(0, 32).addBox(-9.0F, 0.0F, -2.0F, 18.0F, 4.0F, 4.0F, 0.25F, false);

   }

   public void setRotationAngle(ModelRenderer modelRenderer, float x, float y, float z) {
      modelRenderer.rotateAngleX = x;
      modelRenderer.rotateAngleY = y;
      modelRenderer.rotateAngleZ = z;
   }
}

This was your original custom_model class, it exists and you do not need to create another one, so delete the last things you added. The custom_model class, from what i can see by your picture is located in com.isyriux.divinerod.armour package, right? Which is the same package as the PowerReenforcedArmourItem class...so in theory you do not even need to import the package.

Check out the port of the BetterEnd fabric mod (WIP): https://www.curseforge.com/minecraft/mc-mods/betterend-forge-port

Link to comment
Share on other sites

@iSyriux since you asked, I'd really start by reading java tutorials (not watching, who wants to waste 1 hour watching a video when you can read it in 5 minutes?)

 

There're many sources, I referred to geeks for geeks sometimes, https://www.tutorialspoint.com/java/ is also one that I learned java from and alot more, uncle google has the answers

 

Also btw, using a class name such as custom_model isnt really good, would be better if you call it Custom_Model atleast, if anyone was taking a quick look at your code they might think it's a variable instead of a class.

Edited by MostafaSabry55
Link to comment
Share on other sites

6 hours ago, MostafaSabry55 said:

would be better if you call it Custom_Model atleast

Upper camel case is the correct formatting for file names. It should specify what the class is followed by a suffix of the object it's representing. In this case, you are making some power reinforced armor (im american sue me) so it would be PowerReinforcedArmorModel.

 

16 hours ago, iSyriux said:

Also I think you think that I had a custom model class before

I don't need to think you think that I think anything. Your pictures show a name with that class. So what you think that I think isn't applicable to the actual scenario.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hi guys! I currently have a project that I've been developing in a 'vanilla' environment that I'm actually looking to transfer over to Forge, simply because of how much better the experience would be using Forge. Before starting on this Forge mod, I was planning ahead and was looking at options for proxies, of which I would greatly like to use Velocity. In their docs and by asking around their Discord, they don't support support versions of Forge of 1.13 or later because of changes in the "handshake protocol". But I also really don't want to use an unsupported version of Forge, such as 1.12.2, to be able to use a proxy. I was pointed in the direction of potentially making my own client-side mod to allow Forge to be compatible with an updated proxy, such as Velocity. When asking for a direction for achieving this, I was told to have a look at how the Forge server implements logins and that the discrepancy might be with how modified the handshake protocol is. This sounds like quite the challenge to me and I'm completely up for trying to accomplish it. So for the sake of planning ahead and having a rough idea of how I could accomplish that when the time comes to work on it, has anyone else had experience with trying to achieve this? I appreciate any help or direction offered! Thanks! 
    • Been trying to set up a server for myself and a few friends through BisectHosting. I ended up replicating the server on my own computer to see if the issue persisted (if it was on bisect's end) and it was still there. Every time a player tries to connect to the server they start connecting but after only around 2 seconds the player is disconnected with the error message Payload size exceeds 1048576 bytes.  Upon inspection of the server debug file, the player always disconnects while fmlhandshake ticking packet info is being sent, and I have repeatedly made sure the mods and their configs are identical. I tried to get RandomPatches to increase the max allowed byte size, as the default seems to be 32767, but either something is wrong with it or some other mod is limiting the packet size limit.     Server Debug: https://pastebin.com/xZLbtdQB (only includes portions from after the server launched as I couldn't upload the whole file) Server Log: https://pastebin.com/yrJ3tNaW (similarly only after server launched (hence the weird say commands) Client Log: https://pastebin.com/inSzZV96 (whole thing for once) Modlist: https://pastebin.com/Qvurg45j (All but Optifine and BetterFoliage are present on the server as they have caused issues during startup)   Honestly stumped on how to fix this, been working on it for 10 hours across two days to no avail.
    • quiero dormir uwu
    • Hi, mod called "charging gadgets" is crushing forge minecraft 1.18.1 when i place block from this mod, im temporary playing On 1.18 cuz its not happening on 1.18 but c'mon, pls fix it, 1.18.1 is better and I Wonder i could use this version
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.