Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

(1.16.1) How to add another texture layer to chestplate


Recommended Posts

4 hours ago, ChampionAsh5357 said:

Upper camel case is the correct formatting for file names. It should specify what the class is followed by a suffix of the object it's representing. In this case, you are making some power reinforced armor (im american sue me) so it would be PowerReinforcedArmorModel.

True, I've seen some others prefix it with the superclass name, which is also perfectly fine (and easier to spot/find), so ModelPowerReinforcedArmor is good practise too!

Link to comment
Share on other sites

  • 2 weeks later...
3 hours ago, iSyriux said:

Unfortunately, after doing so, I have still the same error I had a few posts ago.

Not trying to be rude, but you clearly don't understand Java enough to do this. You're trying to understand programming through modding by following exact along with whatever script is written out. We are over 100 posts in and you're asking questions that can be solved just by hovering over and reading the error. You don't even seem to be trying to understand what is going on. That teaches you absolutely nothing other than how to fail. If you can't adapt your knowledge and problem solve, you won't be able to learn anything.


So, for the time being, I will request that you stop modding and spend the next portion of your time learning Java up to the point where you don't need to ask a question relating to generics or constructors or anything that is well known Java. If you go about understanding multithreading as well, it becomes a much added bonus. Until you can answer the problem above on your own (as it's quite simple if you understood what generics are), then please take the time to learn. This forum is made to help people specifically with issues in Forge itself and not those brought about by a lack of understanding in Java.


Note: you don't have to listen to me and just call me a rude and curse me out. I'm also not stopping anyone else from helping you solve this problem. I'm just requesting that you actually spend some time on your own to understand what you're writing. Calling yourself a programmer is being able to use your knowledge to adapt to whatever program you are currently using/modifying. Without that knowledge, it will be nothing more than repeating the same questions over and over again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I've been trying to load a custom modpack but it's not letting me create any worlds, it keeps giving me the error "Errors in currently selected datapacks prevented the world from loading. You can either try to load it with only the vanilla data pack ("safe mode") or go back to the title screen to manually fix it". Any way to fix this without needing to remove too many mods? debug log: https://gist.github.com/antxasil/71401fb6a004a66e7248d04d8e7af589
    • I've used forge before, but I can't get it to work with 1.18+   Launcher code: [0116/225441.672:INFO:main_context.cpp(136)] CEF initialized successfully. [0116/225441.673:INFO:main_context.cpp(138)] CEF version: 85.3.13+gcd6cbe0+chromium-85.0.4183.121 [0116/225502.918:WARNING:angle_platform_impl.cc(48)] compileToBinary(257):  C:\fakepath(107,1-13): warning X3557: loop only executes for 1 iteration(s), forcing loop to unroll C:\fakepath(102,1-13): warning X3557: loop only executes for 1 iteration(s), forcing loop to unroll [0116/225508.369:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225515.224:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225515.353:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225525.860:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9581899: LauncherMain.cpp(104)] Initiated models [0116/225525.861:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9592226: LauncherController.cpp(435)] Constructing launcher controller with workDir: C:\...\.minecraft, isActive: 0 [0116/225525.861:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9819604: LauncherAppRenderer.cpp(172)] Javascript bridge extended in OnWebKitInitialized. [0116/225526.215:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=3 [0116/225526.238:INFO:LauncherAppRenderer.cpp(69)] OnBrowserDestroyed: id=3 [0116/225526.387:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=3 [0116/225538.615:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=1 [0116/225825.050:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=5 [0116/230007.904:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=6     "Latest" code [16jan.2022 23:00:09.457] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, Elverea, --version, 1.18.1-forge-39.0.36, --gameDir, C:\Users\Norge\AppData\Roaming\.minecraft, --assetsDir, C:\Users\Norge\AppData\Roaming\.minecraft\assets, --assetIndex, 1.18, --uuid, 31cc9858833c43488f09a460a739f964, --accessToken, ????????, --clientId, NzcyMWNmNWYtZGZhNS00YmY1LWFkMTgtMTljYjVhNzZhODM5, --xuid, 2535453675472907, --userType, msa, --versionType, release, --launchTarget, forgeclient, --fml.forgeVersion, 39.0.36, --fml.mcVersion, 1.18.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20211210.034407] [16jan.2022 23:00:09.462] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 9.0.7+91+master.8569cdf starting: java version 17.0.1 by Microsoft
    • Hello I'm running minecraft server 1.18.1 with forge 39.0.36 in ubuntu and tried to remove a mod, even thou the server starts it throws a bunch of  "Found a missing id from the world", I did the -Dfml.queryResult=confirm but it shows also tried to run the command directly like fml confirm and it throws ¿Which is the correct solution to get rid of all the "Found a missing id from the world" in 39.0.36?
  • Topics

  • Who's Online (See full list)

  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.