• Recently Browsing

    No registered users viewing this page.

  • Posts

    • I'll definitely consider IItemHandler down the line, thanks. With openGui() I was passing the¬†block pos: NetworkHooks.openGui((ServerPlayerEntity) player, ((INamedContainerProvider) tileentity), t -> t.writeBlockPos(pos)); ¬† So the problem is this isn't synced with the client? Would sending a packet resolve it? Or using the getUpdatePacket() and onDataPacket() methods?
    • ---- Minecraft Crash Report ---- // You should try our sister game, Minceraft! Time: 10/29/20 4:02 PM Description: Initializing game java.lang.NullPointerException: Initializing game ¬†¬† ¬†at net.minecraftforge.fml.loading.BackgroundWaiter.runAndTick(BackgroundWaiter.java:32) ~[forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-launcher.jar:31.2] {} ¬†¬† ¬†at net.minecraft.client.Minecraft.<init>(Minecraft.java:358) [forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-recomp.jar:?] {} ¬†¬† ¬†at net.minecraft.client.main.Main.main(Main.java:141) [forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-recomp.jar:?] {} ¬†¬† ¬†at mcp.client.Start.main(Start.java:17) [forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-recomp.jar:?] {} A detailed walkthrough of the error, its code path and all known details is as follows: --------------------------------------------------------------------------------------- -- Head -- Thread: Render thread Stacktrace: ¬†¬† ¬†at net.minecraftforge.fml.loading.BackgroundWaiter.runAndTick(BackgroundWaiter.java:32) ¬†¬† ¬†at net.minecraft.client.Minecraft.<init>(Minecraft.java:358) -- Initialization -- Details: Stacktrace: ¬†¬† ¬†at net.minecraft.client.main.Main.main(Main.java:141) ¬†¬† ¬†at mcp.client.Start.main(Start.java:17) -- System Details -- Details: ¬†¬† ¬†Minecraft Version: 1.15.2 ¬†¬† ¬†Minecraft Version ID: 1.15.2 ¬†¬† ¬†Operating System: Windows 10 (amd64) version 10.0 ¬†¬† ¬†Java Version: 1.8.0_271, Oracle Corporation ¬†¬† ¬†Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation ¬†¬† ¬†Memory: 101809080 bytes (97 MB) / 160432128 bytes (153 MB) up to 1875378176 bytes (1788 MB) ¬†¬† ¬†CPUs: 8 ¬†¬† ¬†JVM Flags: 0 total;¬† ¬†¬† ¬†Launched Version: mcp ¬†¬† ¬†Backend library: LWJGL version 3.2.2 build 10 ¬†¬† ¬†Backend API: NO CONTEXT ¬†¬† ¬†GL Caps:¬† ¬†¬† ¬†Using VBOs: Yes ¬†¬† ¬†Is Modded: Definitely; Client brand changed to 'forge' ¬†¬† ¬†Type: Client (map_client.txt) ¬†¬† ¬†CPU: <unknown>
    • 1.12¬†is no longer supported on this forum. Please update to a modern version of Minecraft to receive support.
    • What do you mean by they won't show up?
    • From what I can see, you are not using the BlockPos you are sending NetworkHooks.openGui(), and thus the 'dummy' ModTileEntity the container creates on the client will have a null BlockPos. ¬† As a side note, I would encourage you to stay away from LockableLootTileEntity and IInventory, and instead use the recommended forge alternative IItemHandler.
  • Topics

  • Who's Online (See full list)