• Recently Browsing

    No registered users viewing this page.

  • Posts

    • I play on Hypixel using some mods, so I use Forge for that. I have an epic gaming session for like 30-40mins and then I get kicked with following messages: These tend to vary a lot, but it seems that it always has the part: "Internal Exception: io.netty.handler.codec.DecoderException:" I have tried playing with Vanilla (no Forge) and everything was completely fine for like 3-4 hours, so I can verify that it only occurs on Forge. I am also pretty sure this started happening to me the night after I updated Windows and used KMS hacktool (well I live in Russia, so we cant like afford normal license).  I wish you could help me guys with that.   This issue is really annoying and I am fully committed to providing you with any additional information if you want to try to help me. Ok so, to knock off obvious answers to fix it I tried: completely reinstalling Minecraft, rebooting my PC, restarting my Wi-FI router. As you can see from the ways of me trying to solve it, I am not the sharpest tool in the shed. I am also fairly new to forums, so let me know if I did something wrong and how to improve
    • If i remove all json files, I can not see pink-black cube... Minecraft combines TESR and json models. How i can do it?
    • Hello there,   I'm working on an Item that should work like a really powerful highlighter. So if you right click on any mob, it should be set Glowing and if you click again, set not Glowing. But I ran into a problem with the Event so I cant get it to work properly. I tested with Villagers and it worked, but with Pigs, Cows and Foxes it didnt. I want it to work on all Animals and Monsters.   So here is my Event Code where I think the Problem is: package com.stevenpaw.awesomeshop.events; import com.stevenpaw.awesomeshop.AwesomeShop; import com.stevenpaw.awesomeshop.init.ModItems; import net.minecraft.entity.Entity; import net.minecraft.entity.player.PlayerEntity; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.event.entity.player.PlayerInteractEvent; import net.minecraftforge.eventbus.api.SubscribeEvent; import net.minecraftforge.fml.common.Mod; @Mod.EventBusSubscriber(modid = AwesomeShop.MOD_ID, bus = Mod.EventBusSubscriber.Bus.FORGE, value = Dist.CLIENT) public class ModClientEvents { @SubscribeEvent public static void onInteractEntity(PlayerInteractEvent.EntityInteract event) { PlayerEntity player = event.getPlayer(); if(player.getHeldItemMainhand().getItem() == ModItems.HIGHLIGHTER.get()) { Entity target = (Entity) event.getTarget(); if(target.isGlowing()) { target.setGlowing(false); } else { target.setGlowing(true); } } } } ModItems.HIGHLIGHTER is the custom Item that I created and AwesomeShop.MOD_ID is the ModID. Maybe it's the wrong Event i'm working with? I tried many things but nothing helps. Maybe you can help me! Thank you! If you need anything else from me to help, please comment.   newest Forge 1.16.4 GitHub for the full Repository
    • Well, it's the reason his item wasn't being accepted, was it not? The line required an instance of an item, not the item itself which with a DeferredRegister is handled with .get()?
    • nvm. i added all that stuff back. it works now!
  • Topics

  • Who's Online (See full list)