• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Thanks for the hint. As I'm not that experienced with the model definitions I had to look some up, but I got it to work.   I now use the following model (if someone has the same problem) { "parent": "block/block", "textures": { "all": "icedresources:blocks/base_block" }, "elements": [ { "from": [ 0, 0, 0 ], "to": [ 16, 16, 16 ], "faces": { "north": { "uv": [ 0, 0, 16, 16 ], "texture": "#all", "tintindex": 0 }, "east": { "uv": [ 0, 0, 16, 16 ], "texture": "#all", "tintindex": 0 }, "south": { "uv": [ 0, 0, 16, 16 ], "texture": "#all", "tintindex": 0 }, "west": { "uv": [ 0, 0, 16, 16 ], "texture": "#all", "tintindex": 0 }, "up": { "uv": [ 0, 0, 16, 16 ], "texture": "#all", "tintindex": 0 }, "down": { "uv": [ 0, 0, 16, 16 ], "texture": "#all", "tintindex": 0 } } } ] }   Just change the block Texture and you can use it as a template/parent in your flat blocks you want to tint.   And your specific block.json files can then be as slim as: { "parent": "icedresources:block/base_block" }  
    • i found out that when you are on a horse and go deep under the water you can drown on normal minecraft the horse automaticly ejects you but on 1.16.1 it doesnt
    • I found the error: In the tile entity when i create the ccntainer in the method createMenu I have to pass the IInventory of the tile entity or the tile entity will not be notified   @Override protected Container createMenu(int id, PlayerInventory player) { LOGGER.info("HELLO FROM createMenu id=" + id + " player=" + player); //the third parameter "this" is the IInventory implemented by the tile entity // ChestContainer container = ChestContainer.createGeneric9X3(id, player, this); ContainerGcmBookshelf container2 = ContainerGcmBookshelf.createGeneric9X3(id, player, this); return container2; }  
    • I know this is somewhat of an older thread however I was wondering if this was ever resolved as i am getting this EXACT same error. It is kind of strange actually that it is literally the same.   Here is my latest: https://hastebin.com/oyebubawit.sql Here is my debug: https://hastebin.com/dehohefudo.md (only took the bottom piece of it where the actual Frozen state happened)   As for the reproduction - it is identical to above. It works flawlessly on Singleplayer. Only in the multiplayer environment does this occur. To be honest I wouldn't even know where to look for something like this? I mean are byte issues generally in networking and packet handling? Yes I can show the code as messy as it may currently be if this has indeed not actually been resolved and is still out and about. But I wouldnt even know which sections of the code would cause this to show.
    • actually nevermind, tysm! it worked!
  • Topics

  • Who's Online (See full list)