• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hello, I started modding a few days ago and now I'm trying to add a new Item just for testing but for some reason the name on en_us.json, and my texture are not showing up in game. It only shows the java name of the item like (item.keanumod.card). I have tried multiple things but none of them worked. Tried : 1- Changing text the text file enconding. (to UFT-8) 2- Changing workspace in Eclipse 3- Downloaded IntelliJ, and the same thing happened 4- I did re-write the whole again, and it still did not work. 5- And tried to change the text format in .jsons to old ones like ""="" instead of "":"" in en_us.json This is my en_us.json :  {     "item.keanumod.card":"Delayed Card" } ================================================================= card.json : {   "parent": "item/generated",   "textures": {     "layer0": "keanumod:items/card"   } } ========================================================================== A print of my structure : https://prnt.sc/vv7bmj ============================================================================ latest log: https://pastebin.pl/view/8b79ffa8 ============================================================================== Just to clarify, the item shows up on my world but withou any texture and named "item.keanumod.card".  Thanks to anyone who did read, I would love some help.   
    • Every time i try to launch the game as forge, it crashes immediately.
    • BlockPos.getAllInBox(...) would be a much, much better way of handling that loop. Or hell, using three nested loops for x, y, and z...
    • Hi, I made a pickaxe in my mod that I actually want it to break ore veins more easily, so I made a blockbreakevent, and then a script that checks for every block around the ore you broke if there are any blocks of the same type, and if there are, then break them. My script is actually not working, and I don't really know why 😅, so I post this for any help, I would really appreciate it. Thanks !   Here is my event : @SubscribeEvent public static void onBreakEventWithPickaxe(BlockEvent.BreakEvent e) { PlayerEntity playerIn = e.getPlayer(); Item pickaxe = ModItems.NETHER_STAR_PICKAXE.get(); Block block = e.getState().getBlock(); IWorld world = e.getWorld(); if (e.getState().getBlock() instanceof OreBlock && playerIn.getHeldItemMainhand().getItem() == pickaxe) { int radius = 3; int height = 6; int posX = e.getPos().getX() - radius; int posY = e.getPos().getY() - radius; int posZ = e.getPos().getZ() - (height / 2); for (int i = 0; i < radius * 2 * radius * 2 * height; i++) { BlockPos pos = new BlockPos(posX, posY, posZ); if (world.getBlockState(pos).getBlock() == block) { world.destroyBlock(pos, true); } posX++; if (posX == radius * 2 + 1) { posY++; posX = e.getPos().getX() - radius; } if (posY == radius * 2 + 1) { posZ++; posY = e.getPos().getY() - radius; posX = e.getPos().getX() - radius; } } } }  
    • You should really keep installations separate. How exactly are you launching server?
  • Topics

  • Who's Online (See full list)