Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.16.3] [SOLVED] Command Arguments


jstN0body
 Share

Recommended Posts

Trying to add an argument to my command, but whenever I run the command it tells me that the command is "unknown or incomplete". I can't find any real error message other than that. Anyone know what I did wrong here?
 

public class SizeCommand implements Command<CommandSource> {

    private static final SizeCommand COMMAND = new SizeCommand();
    
    public static ArgumentBuilder<CommandSource, ?> register(CommandDispatcher<CommandSource> dispatcher) {
        return Commands.literal("scale")
                .then(Commands.argument("size", FloatArgumentType.floatArg()))
                .requires(cs -> cs.hasPermissionLevel(0))
                .executes(COMMAND);
    }

    @Override
    public int run(CommandContext<CommandSource> context) throws CommandSyntaxException {
        ServerPlayerEntity player = context.getSource().asPlayer();
        SizeMod.sizePercentage = FloatArgumentType.getFloat(context, "size");
        player.sendStatusMessage(new TranslationTextComponent("Size updated."), true);
        return 0;
    }
}

 

Edited by jstN0body
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.