Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How to ose non cubic model as mod-item?


Drachenbauer
 Share

Recommended Posts

1 hour ago, Drachenbauer said:

but in "SharedMonsterAttributes" i cannot find the "ENTITY_GRAVITY" attribute.

6 hours ago, diesieben07 said:

You need to use ForgeMod.ENTITY_GRAVITY,

 

1 hour ago, Drachenbauer said:

If i replace "SharedMonsterAttributes" with "ForgeMod", it also cannot find "ENTITY_GRAVITY" in there...

No idea what you are doing, but it definitely exists:

https://github.com/MinecraftForge/MinecraftForge/blob/93c00b67d97b4c51dff4c807e29556bf8a9b7548/src/main/java/net/minecraftforge/common/ForgeMod.java#L97

Link to comment
Share on other sites

I try to use this:

public Multimap<String, AttributeModifier> getAttributeModifiers(EquipmentSlotType equipmentSlot)
    {
        Multimap<String, AttributeModifier> multimap = super.getAttributeModifiers(equipmentSlot);
        
        if (equipmentSlot == EquipmentSlotType.MAINHAND)
        {
            multimap.put(LivingEntity.ENTITY_GRAVITY.getName(), new AttributeModifier(LivingEntity.SLOW_FALLING_ID, "Slow falling acceleration reduction", -0.07, AttributeModifier.Operation.ADDITION).setSaved(false));
        }
        
        return multimap;
    }
  

But i still have a problem with this line:

multimap.put(LivingEntity.ENTITY_GRAVITY.getName(), new AttributeModifier(LivingEntity.SLOW_FALLING_ID, "Slow falling acceleration reduction", -0.07, AttributeModifier.Operation.ADDITION).setSaved(false));

i cannot use LivingEntity.SLOW_FALLING_ID, because it´s private

So i tryed this:

multimap.put(LivingEntity.ENTITY_GRAVITY.getName(), LivingEntity.SLOW_FALLING);

But LivingEntity.SLOW_FALLING is also private.

what is the right setup for this line?

Link to comment
Share on other sites

6 minutes ago, Drachenbauer said:

In the existing one letters where uppercase, in the one from the page, letters are lowercase.

Does this matter?

Please try to get into the habit of doing some very basic research.

The UUID instance is created using UUID.fromString in the example. Searching for "Java uuid from string case sensitive" leads to this very informative StackOverflow post: https://stackoverflow.com/a/13833488. I recommend you read and understand it before working with UUIDs.

Link to comment
Share on other sites

https://www.youtube.com/watch?v=6te-IdUIBdY

here he hoints his arm up while holding an umbrella.at the end of the video.

 

but there in no link to the mod with the umbrella...

 

I notived, i fall slower with the umbrella, bot still get a tiny little bit of damage on landing.

How to remove the fall damage compleetely, if holding that item?

 

Edit: i canceled the LivingFallEvent, if holding the umbrella.

Now i can jump from as high as i want with the umbrella without being damaged.

Edited by Drachenbauer
Link to comment
Share on other sites

  • 2 weeks later...

I noticed, that i can jump higher, if holding this umbrella.

Than i saw a video of someone, who made a tower of scaffolding, placed a cage of scaffolfing ontop and filled it with chckens.

Then he removed the bottom scaffolding and the chickens fell down slowly and took no damage at landing on the ground.

how can i attach this exact behavior to my umbrella?

 

In the ChickenEntitx-Class i find just this:

    public boolean onLivingFall(float distance, float damageMultiplier)
    {
        return false;
    }

But nothing about the falling-speed.

Edited by Drachenbauer
Link to comment
Share on other sites

now i try this solution:

https://forums.minecraftforge.net/topic/83298-solved-1152-different-item-model-when-rendered-in-the-inventory-vs-handheld/

 

It uses the deprecated variant of getQuads.

but if i try to replace it with the better one, new IBakedModel() says, that i have to use the old one, because it´s an unimplemented method.

How can i use the new one without this error?

 

Now i found IForgeBakedModel.

How can i use it instead of IBakedModel here?

Edited by Drachenbauer
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hi guys! I currently have a project that I've been developing in a 'vanilla' environment that I'm actually looking to transfer over to Forge, simply because of how much better the experience would be using Forge. Before starting on this Forge mod, I was planning ahead and was looking at options for proxies, of which I would greatly like to use Velocity. In their docs and by asking around their Discord, they don't support support versions of Forge of 1.13 or later because of changes in the "handshake protocol". But I also really don't want to use an unsupported version of Forge, such as 1.12.2, to be able to use a proxy. I was pointed in the direction of potentially making my own client-side mod to allow Forge to be compatible with an updated proxy, such as Velocity. When asking for a direction for achieving this, I was told to have a look at how the Forge server implements logins and that the discrepancy might be with how modified the handshake protocol is. This sounds like quite the challenge to me and I'm completely up for trying to accomplish it. So for the sake of planning ahead and having a rough idea of how I could accomplish that when the time comes to work on it, has anyone else had experience with trying to achieve this? I appreciate any help or direction offered! Thanks! 
    • Been trying to set up a server for myself and a few friends through BisectHosting. I ended up replicating the server on my own computer to see if the issue persisted (if it was on bisect's end) and it was still there. Every time a player tries to connect to the server they start connecting but after only around 2 seconds the player is disconnected with the error message Payload size exceeds 1048576 bytes.  Upon inspection of the server debug file, the player always disconnects while fmlhandshake ticking packet info is being sent, and I have repeatedly made sure the mods and their configs are identical. I tried to get RandomPatches to increase the max allowed byte size, as the default seems to be 32767, but either something is wrong with it or some other mod is limiting the packet size limit.     Server Debug: https://pastebin.com/xZLbtdQB (only includes portions from after the server launched as I couldn't upload the whole file) Server Log: https://pastebin.com/yrJ3tNaW (similarly only after server launched (hence the weird say commands) Client Log: https://pastebin.com/inSzZV96 (whole thing for once) Modlist: https://pastebin.com/Qvurg45j (All but Optifine and BetterFoliage are present on the server as they have caused issues during startup)   Honestly stumped on how to fix this, been working on it for 10 hours across two days to no avail.
    • quiero dormir uwu
    • Hi, mod called "charging gadgets" is crushing forge minecraft 1.18.1 when i place block from this mod, im temporary playing On 1.18 cuz its not happening on 1.18 but c'mon, pls fix it, 1.18.1 is better and I Wonder i could use this version
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.