Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.15.2]Modded Block Not Registering Into Minecraft[solved]


Somonestolemyusername
 Share

Recommended Posts

3 minutes ago, Somonestolemyusername said:

also i do not understand what u meant  to say here

I told you: "Your issue is because you did not add a BlockItem for your blocks". You then added the BlockItem for netherite_block. Then you complained that it still did not work for the ore.

I am baffled by this, because you obviously did not apply the fix for the ore and yet are surprised that the ore is still broken.

Link to comment
Share on other sites

the ore isint broken it works perfectly its just like the netherite block(the ore did not get deleted) it did not appear in the inv. but when i add block items to the ore it gives an error for OreGeneration.java because its supposed to be 

 

RegistryHandler.NETHERITE_ORE.get().getDefaultState(), 10))

and I dont know what i would change it to if i make it with the ItemList.netherite_ore method

 

Link to comment
Share on other sites

7 minutes ago, Somonestolemyusername said:

well i want to do it with DeferredRegister but I dont know how im going to add it in with that. I was gonna watch the technovison tut but he made his vids unlisted so idk how im gonna make the block item with deferred register

You could always read the documentation on how to use deferred register.

Link to comment
Share on other sites

24 minutes ago, diesieben07 said:

I told you: "Your issue is because you did not add a BlockItem for your blocks". You then added the BlockItem for netherite_block. Then you complained that it still did not work for the ore.

I am baffled by this, because you obviously did not apply the fix for the ore and yet are surprised that the ore is still broken.

i did say it was for the ore because i also added that to it but then acedently undoed all of it which made me lose everything i wrote there

 

Edited by Somonestolemyusername
Link to comment
Share on other sites

37 minutes ago, Somonestolemyusername said:

wait but i mean what do i use in it to connect it to the block

 like for netherite_block would i use netherite_block_item?

Give them the same registry name.

 

22 minutes ago, Somonestolemyusername said:

im trying to add the blockitem to ModItemGroup but its not letting me 

What do you mean by "not letting me"? Show errors and code.

Link to comment
Share on other sites

38 minutes ago, Somonestolemyusername said:

wait but i mean what do i use in it to connect it to the block

 like for netherite_block would i use netherite_block_item?

Look at the constuctor of BlockItem. It askes for a Block to bind it to.

You can give it the same registry name.

Edited by Danebi
Link to comment
Share on other sites

  • Somonestolemyusername changed the title to [1.15.2]Modded Block Not Registering Into Minecraft[solved]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.