• Recently Browsing

    No registered users viewing this page.

  • Posts

    • I have the server on forge 1.16.4-35.1.37 that I host from my own pc for my friends I've spent about 3 hours now trying to figure out what wrong and I just can't find it myself, can someone more experienced with forge help me out? I included the crash log and the mod list crash-2021-01-21_08.59.11-server.txt modlist.html
    • I guess i did it. public <T> LazyOptional<T> create(LivingEntity entity) { LazyOptional<IItemHandlerModifiable>[] ret = new LazyOptional[2]; ret[0] = LazyOptional.of(() -> getHandler()); ret[1] = LazyOptional.of(() -> new EntityArmorInvWrapper(entity)); return LazyOptional.of(() -> (T)new CombinedInvWrapper(ret[0].orElse(null), ret[1].orElse(null))); } public <T> LazyOptional<T> getCapability(@Nonnull Capability<T> cap, @Nullable Direction side) { if(cap == CapabilityItemHandler.ITEM_HANDLER_CAPABILITY) { // super.getCapability(cap, side).; return create(this); } return super.getCapability(cap, side); }   But how would a slot know if its a default or a custom slot   en.getCapability(CapabilityItemHandler.ITEM_HANDLER_CAPABILITY).ifPresent(h -> { int index = 0; for(int i =8;i < 63;i+=18) { final EquipmentSlotType equipmentslottype = VALID_EQUIPMENT_SLOTS[index]; addSlot(new SlotItemHandler(h,index,8,i){ public int getSlotStackLimit() { return 1; } public boolean isItemValid(ItemStack stack) { return stack.canEquip(equipmentslottype, en); } public boolean canTakeStack(PlayerEntity playerIn) { ItemStack itemstack = this.getStack(); return !itemstack.isEmpty() && !playerIn.isCreative() && EnchantmentHelper.hasBindingCurse(itemstack) ? false : super.canTakeStack(playerIn); } @OnlyIn(Dist.CLIENT) public Pair<ResourceLocation, ResourceLocation> getBackground() { return Pair.of(PlayerContainer.LOCATION_BLOCKS_TEXTURE, MyModContainer.ARMOR_SLOT_TEXTURES[equipmentslottype.getIndex()]); } }); index++; } });
    • Brand new fully functional Skyblock server! Join now to help develop a new community. Regular updates and new gamemodes soon... IP:
    • So, I started hosting RLCraft server on my PC few days ago. My friends can join, but can't actually do anything, they can move on their screen and break blocks (altough the blocks they break don't drop anything) and they can't hit mobs. On my screen they're actually afk and just standing. If they get killed somehow, I get notification in command prompt, but they can still move on their screen. Then I get notification they lost connection: Disconnected and left the game. I'm running newest version of RLCraft (v2.8.2.) and we both have the same newest version (I downloaded it from CurseForge, as well as server files). We're not using port forwarding, we're using Hamachi and there are no problems with it. We ran diagnose checks on ourselves and on the others and everything is perfect with Hamachi. I can connect to the server normally by using "localhost" as the server address, and I can even play using Hamachi IP (same one they type as server address) and I can play normally on both, but they can't for some reason. For them, server is pinging for like 10 seconds, then it shows online and they join. It stays on "Connecting" for a 10-20 seconds, then they start logging in for approximately the same amount of time, and I can see that in logs and for now everything looks fine and then around 20 seconds later they get disconnected. They get "Internal Exception: java.io.IOException: An existing connection was forcibly closed by the remote host" and in logs (command prompt) I get : [11:12:28] [Netty Server IO #6/ERROR] [FML]: NetworkDispatcher exception io.netty.handler.timeout.ReadTimeoutException: null [11:12:28] [Server thread/INFO] [minecraft/NetHandlerPlayServer]: Okmaner lost connection: Disconnected [11:12:28] [Server thread/INFO] [minecraft/DedicatedServer]: Okmaner left the game We're running newest version of Java (Version 8 Update 281). Server has a lot of RAM allowed to use (7-8 gigabytes) and it never used more than 4 gigabytes at once, I don't think its RAM problem. We also allowed both Hamachi and Java trough firewall, both Inbound and Outbound rules (in Windows Defender Firewall with Advanced Security). I also put the port 25565 (default port) I'm using for server in both Inbound and Outbound rules and I allowed everything I suspected to be the Issue (connected with Java and/or Hamachi and Minecraft) trough firewall. Should I maybe disable on of the mods in RLCraft? I also tried putting in RandomPatches mod in server mods and thought what would fix the issue but it didn't. I also lowered view distance in server.properties to only 2 and that didn't fixed an issue (before it was 6 chunks view distance). I have 16GB of RAM, AMD Ryzen 5 2600X Six-Core Processor 3.60 GHz (processor) and NVIDIA GeForce GTX 1650 SUPER (graphics card). I will put 4 log screenshots, screenshot of all mods in the server files and screenshot of start.bat file (I use it to start the server) and server.properties file down below. If you need more screenshots or details I will put it in the comments. I really hope someone might have a solution, because nothing we tried worked. Thanks!
    • Hi, could anyone tell me how to set entity attributes for my custom mob, please? I copied the code that most of the vanilla mobs use, but judging from the log, it doesn't seem to be working. I found this post, but it appears to be out of date.   Thanks.
  • Topics

  • Who's Online (See full list)