Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

how do I config mods in 1.16.4?


Recommended Posts

I installed forge as per normal, latest 1.16.4 (though I got this error with the recommended as well), then proceeded to download and place the mod jars in the mods folder. Then I get this:

"secure mod features disabled update jdk"

And I can't go into any of the mod's config settings. the only mod that I can configure is the API "Cloth Config v4 API"

Now, I've seen this prompt asked about in older threads, but those in the know seem to be tight-lipped about it, insisting that this does not stop the mods from working, that I should just ignore the prompt and ultimately that this is a good thing. While, yes, I can use every mod installed in the mods folder, there are some functionalities to the mod that I'm locked out of because of this JDK thing.

I know I can't recompile base minecraft for the latest Java Developer's Kit, nor is that any of our responsibilities. I just want to know it there's a workaround for letting someone get into their configs in 1.16.4 using forge 35.1.37.

Link to post
Share on other sites
5 hours ago, sc0rich said:

Then I get this:

"secure mod features disabled update jdk"

Not an error message.

 

5 hours ago, sc0rich said:

And I can't go into any of the mod's config settings. the only mod that I can configure is the API "Cloth Config v4 API"

Then those mods didn't add a config screen.

 

5 hours ago, sc0rich said:

there are some functionalities to the mod that I'm locked out of because of this JDK thing.

Untrue. Also entirely unrelated to the configuration screens.

 

5 hours ago, sc0rich said:

I know I can't recompile base minecraft for the latest Java Developer's Kit, nor is that any of our responsibilities. I just want to know it there's a workaround for letting someone get into their configs in 1.16.4 using forge 35.1.37.

None of this makes any sense.

If you want the "secure mod features" (which is simply a verification that the jar files have not been tampered with, it's not any mod functionality), update your Java to latest Java 8.

Link to post
Share on other sites

debug.log

20 hours ago, diesieben07 said:

Not an error message.

I know it's not an error message. that's why I didn't type that it was an error message. If you felt like I implied it, I didn't mean to imply that. I assume that's the launcher running a part of its program as intended and I screwed up somewhere. Presumably, as far as the latest Java 8.

But that's not the problem. I've had Java 8 update 281 since late January, so before I even downloaded mods for 1.16.4. Like, I've ran 1.12.2, 1.10.2 and 1.7.10 all with forge and associated mods w/o problem. It's only been within the last couple of weeks I've had problems. Like I said, the mods play fine, but I can't get into the config files. Which as mentioned above are in fact not the "Secure mod features."

FWIW the launcher itself keeps warning me that "This installation has been modified and might not support the latest player features." (no shit, sherlock) I didn't care before cause those player features are chat based and I'm playing singleplayer. But again, this may not have anything to do with anything.

Is there perhaps something in the logs that re-enables configs? For mods that I know have them, because I played earlier releases. spacer.png

hey doc...png

yeah, so.png

they're all like this.png

zoom in.png

 

edit: tried the java update method on the minecraft Gamepedia site (/Tutorials/Update_Java) - same problem as, just now it says "signiture: Unsigned. Trust: none."  So obviously, what I did was the wrong way. now I need help figuring out the right way to make MC run Java 8 - 281. I can make a copy installation with default java executable to restore the file in question to a state before I messed the java update part up.

crafttweaker.log latest.log

Edited by sc0rich
included logs, update on my situation.
Link to post
Share on other sites
8 hours ago, sc0rich said:

ame problem as, just now it says "signiture: Unsigned. Trust: none."

No, that just means the mod has not signed their jar file (most mods don't).

 

Again, this has nothing to do with the Config button. The Config button is only enabled if the mod provides a Config GUI (most mods don't).

Link to post
Share on other sites

Oh, okay.

 

 

 

wait, then how do I access the configurations? do you know where do I go? how I edit .cfg and .toml files? cause I just found it -_-

Edited by sc0rich
realized I have to go into the code. I h8 going into the code - I feel like I'm gonna break something
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Then give us a log of you running on a supported java version.
    • i already tried downloading java 8,  the servers always worked up until now  
    • Whenever i start it this showns   C:\Users\sidne\OneDrive\Desktop\Japanese Themed>java -Xmx4096M -Xms4096M -jar forgeserver.jar nogui 2021-04-16 07:33:50,531 main WARN Advanced terminal features are not available in this environment [07:33:50] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 35.1.4, --fml.mcpVersion, 20201102.104115, --fml.mcVersion, 1.16.4, --fml.forgeGroup, net.minecraftforge, nogui] [07:33:50] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.6+85+master.325de55 starting: java version 16 by Oracle Corporation Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x55a1c291) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x55a1c291         at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41)         at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)         at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41)         at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)         at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)         at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)         at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)         at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)         at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)         at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)         at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)         at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)         at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) C:\Users\sidne\OneDrive\Desktop\Japanese Themed>PAUSE Press any key to continue . . . PLEASE HELP  
    • I know that the latest version of forge no longer uses the forge but the mojang mappings therefore i cannot find some methods is there a list or something similar where i can find the new name of the method I would find the methods myself, if not most of the classes look like this: here are some methods with their old names VoxelShapes#combineAndSimplify Block#updatePostPlacement Block#allowsMovement does anyone know the new mapping names? and does anyone have any idea why many classes are not readable / look strange?  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.