Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Solved] Registering custom flowers as compostable


Recommended Posts

In my mod I have several custom flower types (instances of FlowerBlock), which I register using the DeferredRegister. Now I want to add them to the composter's registry of compostable items. I know I need to add them to ComposterBlock.CHANCES, but I don't know when exactly I need to do this. When I call ComposterBlock.CHANCES.put() in my mod's main class's constructor, I get a NullPointerException with the message 'Registry Object not present: my_mod:my_flower', even though I created the flower objects before I tried to register them. I suspect I need to call this at a later time, but I couldn't find any information about this anywhere.

Edited by jonaskohl
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hi, I have about 63 mods, and the pack worked fine a day ago, but now it launched up, loads with the big red Mojang screen, then freezes when it is "freezing data".  It loads for like 7 minutes then crashes.  Sorry if i posted something wrong.  Here is mods: I also have Optifine....And here is crash report: I have tried reinstalling MC, forge, changed the forge profile version, deleting resource packs, updating and downgrading Universal Mod Core, and adding more Ram.  I currently give it 4GB out of 16GB, any less and it won"t work, but 6GB is too much, because then it gets lag spikes.  Any help would be greatly appreciated. Thanks
    • I'm running on a brand new, clean Windows 10 install. Fresh download of minecraft, Java and the modpack. I have 6 of 8 Gb of ram allocated, which worked before the new install. Running on an old laptop with integrated graphics and outdated everything, but it has worked so far with lowered graphics settings. The load gets about half way, then crashes with this report: https://pastebin.com/KTa7fmyf. This is my first time using pastebin, so hopefully I did that right.
    • My game crash with [19:22:26] [Client thread/WARN] [FML]: Registry Item: Override did not have an associated owner object. Name: testymod:axe_copper Value: com.Testmod.objects.tools.ToolAxe@1f41742f [19:22:27] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:553]: ---- Minecraft Crash Report ---- // Hey, that tickles! Hehehe![19:22:26] [Client thread/WARN] [FML]: Registry Item: Override did not have an associated owner object. Name: testymod:axe_copper Value: com.Testmod.objects.tools.ToolAxe@1f41742f [19:22:27] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:553]: ---- Minecraft Crash Report ---- // Hey, that tickles! Hehehe!  
    • if I'm not mistaken: you just add two conditions in the json array for conditions, one to check for the tool enchantment, and one to check for a random rol. you can look at the glass loot table to see how to check for the enchantment, and at the grass loot table to see how to drop on a random chance with a given probability
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.