Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

(1.16.5) Please help with Immersive Petroleum mod!


Tatarami
 Share

Recommended Posts

Recently, my friend sent me mods for his server and one of them was called "ImmersivePetroleum-1.16.4-3.1.0-2.jar"

When I first added this mod it did not work, so I downloaded the most recent version, for 1.16.5.

This one didn't work either.

So since my friends used the 1.16.4 version on a 1.16.5 server without any problems, I tried to run it again, but this time it said "Immersive Petroleum (immersivepetroleum) has failed to load correctly"

And below that, it was "java.lang.RuntineException: Cannot find class"

 

Here's the crash log : https://pastebin.com/LKuYnjtp

 

I just don't know what causes the issue. Can somebody please help? 

Thanks! 

!image.thumb.png.599c82c9fa9d28503371f895f06ab13d.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello I made a server forge with mods but when I changed it from other pc some mods are bug. I have identified the mods that are bug, here are the logs and the crash reports Logs of the server with the bug mods removed: https://pastebin.com/wDxeM00A Logs of the server with all the bug mods: https://pastebin.com/ssGLVy2W Logs of the server with one bug mod: https://pastebin.com/4XnAuUic I tried to download an older version of the mods but it didn't work. How can I insert that mods? Thanks.
    • I'm not asking for a solution only for 1.16.5, a solution for more current versions will be fine as well
    • I know this chat is outdated but can you guys help me with this because i'm having the same problem and i am unable to get into the files because i am on mac
    • You only ever set the block on the client. See HoneycombItem.useOn() for the "correct" logic.
    • public InteractionResult use(BlockState blockState, Level level, BlockPos blockPos, Player player, InteractionHand hand, BlockHitResult blockHitResult) { ItemStack itemstack = player.getItemInHand(hand); boolean successfullyDyed = false; if (level.isClientSide) { if(player.getAbilities().mayBuild == true){ if(itemstack.getItem() == Items.RED_DYE){ level.setBlock(blockPos,blockState.setValue(TYPE,0),0); successfullyDyed = true; } else if(itemstack.getItem() == Items.ORANGE_DYE){ level.setBlock(blockPos,blockState.setValue(TYPE,1),0); successfullyDyed = true; } else if(itemstack.getItem() == Items.YELLOW_DYE){ level.setBlock(blockPos,blockState.setValue(TYPE,2),0); successfullyDyed = true; } else if(itemstack.getItem() == Items.GREEN_DYE){ level.setBlock(blockPos,blockState.setValue(TYPE,3),0); successfullyDyed = true; } else if(itemstack.getItem() == Items.BLUE_DYE){ level.setBlock(blockPos,blockState.setValue(TYPE,4),0); successfullyDyed = true; } else if(itemstack.getItem() == Items.PURPLE_DYE){ level.setBlock(blockPos,blockState.setValue(TYPE,5),0); successfullyDyed = true; } else{ player.displayClientMessage(Component.translatable("block.thingamajigs.lava_lamp.wrong_dye"), true); return InteractionResult.CONSUME; } // update THIS block, no matter what happens if(successfullyDyed == true){ level.updateNeighborsAt(blockPos,this); level.playSound(null, blockPos, SoundEvents.DYE_USE, SoundSource.BLOCKS, 1.0F, 1.0F); return InteractionResult.SUCCESS; } if(!player.isCreative()) { if (itemstack.getCount() > 1) { itemstack.setCount(itemstack.getCount() - 1); } else { itemstack.setCount(0); } } } } return InteractionResult.CONSUME; } Hey there, I was working on a block's 'use' method, however the behavior is not quite what I wanted. In-game, the block will flash to the desired state, then revert back to the state it was in previously, and won't actually update. I was wondering if perhaps I was updating the block wrong? The only state I am trying to update is an Integer value called 'TYPE' from 0-5 by using dyes.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.