Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Solved] Rendered BlockState defaults to stone


Recommended Posts

So I have created a custom tnt entity, but when it renders, it looks like stone that flashes like tnt does, even though it has a different blockstate (and I have checked and it does in fact have the correct one)

The rendering occurs here:

https://github.com/AyliasTheCoder/ScatterTNT/blob/main/src/main/java/com/aylias/minecraft/mods/scattertnt/client/ScatterTNTRenderer.java

 

it prints out that it is using the blockstate of "scatter_tnt:small_stone_tnt" and that block has a texture, but the lit tnt has the texture of stone.

Edited by NullDev
It was solved!
Link to post
Share on other sites
  • NullDev changed the title to [Solved] Rendered BlockState defaults to stone

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.