Jump to content

[Solved] An Unexpected Error Occured


NullDev

Recommended Posts

I created an entity, and when I try to summon it I just get "An unexpected error occurred trying to execute that command" with no stack trace or anything. Why is this happening? My code:

https://github.com/AyliasTheCoder/BlocksRealsBlockCreatures

The Entity Class Itself:

https://github.com/AyliasTheCoder/BlocksRealsBlockCreatures/blob/master/src/main/java/me/aylias/minecraft/mods/modbase/entities/HayHorse.java

Edited by NullDev
It was solved!
Link to comment
Share on other sites

4 minutes ago, diesieben07 said:

You need to register the attributes for your entity using EntityAttributeCreationEvent.

I have this in my EntityRegisterEvents class:

@SubscribeEvent
public static void registerEntityAttributes(EntityAttributeCreationEvent e) {
	e.put(HAY_HORSE, AttributeModifierMap.createMutableAttribute().createMutableAttribute(Attributes.MAX_HEALTH, 25)
		.createMutableAttribute(Attributes.FOLLOW_RANGE, 16.0)
		.createMutableAttribute(Attributes.ARMOR)
		.create());
}

https://github.com/AyliasTheCoder/BlocksRealsBlockCreatures/blob/master/src/main/java/me/aylias/minecraft/mods/modbase/events/EntityRegisterEvents.java

 

Is something missing from it?

 

Link to comment
Share on other sites

  • NullDev changed the title to [Solved] An Unexpected Error Occured

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.