Jump to content

[HELP] Forge won't open


Recommended Posts

Version: 1.12.2
I tried uninstalling and reinstalling java, restarting my pc, reinstalling forge, installing AdoptOpenJdk and doing the command prompt, nothing worked


Exception in thread "main" java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at net.minecraftforge.installer.Java6Gate.main(Java6Gate.java:48)
Caused by: java.lang.ExceptionInInitializerError
at net.minecraftforge.installer.ClientInstall.getSponsorMessage(ClientInstall.java:401)
at net.minecraftforge.installer.InstallerAction.getSponsorMessage(InstallerAction.java:60)
at net.minecraftforge.installer.InstallerPanel.updateFilePath(InstallerPanel.java:334)
at net.minecraftforge.installer.InstallerPanel.(InstallerPanel.java:315)
at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:167)
at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:54)
... 5 more
Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
at net.minecraftforge.installer.MirrorData.buildMirrorList(MirrorData.java:84)
at net.minecraftforge.installer.MirrorData.(MirrorData.java:63)
at net.minecraftforge.installer.MirrorData.(MirrorData.java:17)
... 11 more

Link to comment
Share on other sites

I had a similar issues, when i would launch forge the launcher would close and then within in a second, i would get exit code: 0 i deleted .minecraft and reinstalled Minecraft and it worked. I don't know if it would work for u but it worked for me, just make sure to back up ur worlds in a folder/ flash drive 

Edited by IronPanda
Link to comment
Share on other sites

1 hour ago, IronPanda said:

Um, hi i am having similar issues, does forge open to the loading screen or crash right after the launcher closes. 


Thx :) 

I double click on it to open it and it just creates a txt file but doesn't bring me to the page to install it 

Link to comment
Share on other sites

This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.