Jump to content

[36.1.0] Gradle build failing


Recommended Posts

I just today tried to rebuild my project on a laptop that I haven't used in a couple of years.  After downloading HEAD, along with the up-to-date MDK, and trying to run gradlew eclipse, the gradle process failed citing "Could not resolve: net.minecraftforge:forge:1.16.5-36.1.0_mapped_snapshot_20210309-1.16.5_at_bafb3e1b42c31582fafe93878f76a7fc577e66fb" and an exception with a stacktrace longer than my terminal buffer.  I've tried deleting the source folder and re-cloning, as well as deleting my entire %APPDATA%\.gradle folder, but to no avail.  Google searching hasn't yielded much, at least for current versions of Forge.  Does anyone have any suggestions as to what I could be missing?  Thank you.

Link to comment
Share on other sites

I think I've found the cause of the problem.  A recently updated Java installation installed just the JRE instead of the JDK, and was causing gradle to be unable to find tools.jar.  Installing the updated version of the JDK seems to have fixed the problem.  Thank you, and I apologize for wasting your time.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.