Jump to content

My forge always fails to load with a mod setup that works for everyone else who tried it


Recommended Posts

Every Time i try to load a modpack that a few friends of mine play, the loader fails to load some mods and spews out an error.
The game works without any mods and the mods it fails to load are different each time which is why i'm posting it here.
This exact set of mods works perfectly fine on both a server and my friends clients who are not getting any errors at all (I know it's the exact same because i sent them the .jars).

Things i tried so far:

  • Create new launcher profile in different folder
  • Completely reinstall Forge, Minecraft and the Minecraft Launcher. Sometimes this made it load exactly once before going back to the errors but it's a bit of a luck thing it seems.
  • Restart PC

I'm at my wits end here so any help is appreciated

Crash Log (at least one of them): https://pastebin.com/nM6tKAJw

latest.log: Google Drive (too big for pastebin apparently)

Link to comment
Share on other sites

1 hour ago, diesieben07 said:

Many of your mod file names suggest you didn't get the mods from their original sources. Check out https://stopmodreposts.org/ for why this is a problem and then obtain your mods properly before doing anything else.

Fair point. Got all the mods from CurseForge now (is that the correct one?) but the problem is still the same, so i still need help.

Link to comment
Share on other sites

Looking through the crash reports, it always seems to be a ClassNotFoundException, but always on different mods and when i look inside the .jar the class is definitely always there.

https://pastebin.com/msJRAvHE Crash report

https://pastebin.com/N8fHhbmN Crash report 2

https://drive.google.com/file/d/1KdBbXrxWBXhh-oS8XuY2rrPu2UMZ5HLs/view?usp=sharing Latest log (still too big for pastebin)

Link to comment
Share on other sites

22 minutes ago, diesieben07 said:

Looks to be an issue with GeckoLib. Make sure you follow the installation instructions.

The only installation instructions for that mod on their page are very clearly directed towards modders intending to make use of the library so i don't see what i could have done wrong there. Re-downloading it didn't work either.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.