Jump to content

[SOLVED] [1.16.5] EntityRenderManager NullPointerException: Unexpected Error

Recommended Posts


I've been trying to mod multiple entities (in this case mobs) into the game. After initially having quite a bit of trouble with the new syntax (last time I wrote a Forge mod was in 1.8) I started to look into existing mods in order to figure things out.

I actually managed to get a single entity to work properly with some mostly copy-pasted code, but after adding a second one, upon trying to summon it, the EntityRenderManager crashed the game with the crash report description that is in the title.

I since rewrote a lot of code because after searching through a bunch of forums it turned out the code I had earlier had a bunch of depreciated stuff in it, but now after the rewrite I still get the same crash but now with both entites (a.k.a. none of them work now).

The full crash report is as follows: https://pastebin.com/0eRdCCxM

My code:

Main Class: https://pastebin.com/6E8nVpqP

Rendering Registries: https://pastebin.com/jn2yx69c

Entity Registries and Attribute Init: https://pastebin.com/zyrtsLeb

Renderer Classes (both are pretty much the same): https://pastebin.com/7wgdSbJN

Edited by TheUltimateEngine
Link to comment
Share on other sites

  • TheUltimateEngine changed the title to [SOLVED] [1.16.5] EntityRenderManager NullPointerException: Unexpected Error

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.