Jump to content

RenderBlocks.renderFaceXXXX naming problems?


Recommended Posts



I'm slowly wrestling my way through the various rendering code and I think I've come across a couple of  mistakes.


RenderBlocks has six renderFace methods (eg renderFaceYNeg), and these renderFace methods use some flags (set by the caller) to alter how the faces are rendered, for example uvRotateEast.


The problem I'm found is that some of these aren't properly named.


For example-

renderFaceZPos uses the uvRotateWest flag, but the positive Z face is south, not west.


Is there a robust way I can change these?  i.e. so I can write

renderBlock.uvRotateSouth = 1; renderBlock.renderFaceZpos();


I don't understand how Forge decompiles the Minecraft jar and gives meaningful names to everything - is this something I can customise (for example - giving better names to the parameters of various interface functions (eg par1, par2)), without having to do it all from scratch every time I update to a new version of Forge? 










Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.