Jump to content

Unable to Open Forge Installer, Creates "installer.log" (Tried opening manually, tried Jarfix)


Recommended Posts

I have downloaded this version of forge: "forge-1.12.2-"

I am unable to open this file by double clicking. When I try to open manually via Windows Powershell: PS D:\Downloads (D)> java -jar forge-1.12.2-
                                                                                                                                                                          Error: Unable to access jarfile forge-1.12.2-

I am in the correct directory. I have tried the same in CMD and I'm pretty sure it was the exact same.

My java is on the latest version.

What confuses me even more is I can open the installer for the latest forge update, but I cannot open older versions. I am using a older version of forge because the latest one has an issue when I try to run a certain mod wherein viewing the modded items crashes the game instantly. However, this older version of forge works with the mod. I actually already have this version of forge installed, and have never had problems installing forge versions in the past, but now that I am trying to help my friend download this version, I am no longer able to open the installer. Very annoying.

When I try to run the installer I get a Installer.log that reads:

Exception in thread "main" java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraftforge.installer.Java6Gate.main(Java6Gate.java:48)
Caused by: java.lang.ExceptionInInitializerError
    at net.minecraftforge.installer.ClientInstall.getSponsorMessage(ClientInstall.java:401)
    at net.minecraftforge.installer.InstallerAction.getSponsorMessage(InstallerAction.java:60)
    at net.minecraftforge.installer.InstallerPanel.updateFilePath(InstallerPanel.java:334)
    at net.minecraftforge.installer.InstallerPanel.<init>(InstallerPanel.java:315)
    at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:167)
    at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:54)
    ... 5 more
Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
    at net.minecraftforge.installer.MirrorData.buildMirrorList(MirrorData.java:84)
    at net.minecraftforge.installer.MirrorData.<init>(MirrorData.java:63)
    at net.minecraftforge.installer.MirrorData.<clinit>(MirrorData.java:17)
    ... 11 more

Again, I have never had problems with this in the past and have installed multiple versions of forge.

If I can resolve the issue of the latest version of forge 1.12.2 causing the game to crash when viewing the modded items added by the Minecraft Modern Warfare mod, that would be fine as well.

Edited by ghetto
I know its an older version of forge but I am forced to use it.
Link to comment
Share on other sites

This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.