Jump to content

Trouble trying to run Forge project 1.18. Classes will not compile with bytecode 55


MrChoke

Recommended Posts

I don't know why IntelliJ and/or Gradle keep doing this.  I have a fresh new install of latest version 21 IntelliJ.  I followed the instructions on how to setup the Forge project with IntelliJ 21.  It all worked great.

I run any of the generated configurations like "Clean Clean Client" for example.  And I get this error:

> Task :clean:Main.main() FAILED
Error: LinkageError occurred while loading main class net.minecraft.client.main.Main
    java.lang.UnsupportedClassVersionError: net/minecraft/client/main/Main has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 55.0

LinkageError occurred while loading main class net.minecraft.client.main.Main
 

It compiled the classes as Java 17, not 11. Sure enough I find the .class files at:  \projects\clean\build\classes\java\main.  I decompile any of them and they are all bytecode 61, not 55.

I have JDK 11 installed.  I have JDK 11 set in all places I can find in Gradle, module settings, SDKs and javac settings.  I made sure I don't have a JDK 17 installed anywhere on my PC either.  Anybody know why its doing this?

Link to comment
Share on other sites

2 hours ago, diesieben07 said:

1.18 requires Java 17. The Gradle Toolchain feature is used to set the Java version. Gradle will install Java 17 if necessary automatically.

Hmmm, At first I tried 17 and then got errors during the build about one of the jars, don't remember which was compiled with 55 and I was using 61.   OK, let me re-install 17 and see how far I get again with that route.  Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.