Jump to content

(1.16.5) Execute command


ElTotisPro50

Recommended Posts

i have an item and if i right click i want to execute a command(from the code) for example /kill @a, i thinked this was going to work but nope, with !world.isRemote is not doing anything and without !world.isRemote minecraft crashes

@Override
    public ActionResult<ItemStack> onItemRightClick(World worldIn, PlayerEntity playerIn, Hand handIn)
    {
        ItemStack stack = playerIn.getHeldItemMainhand();
        if(!worldIn.isRemote)//do nothing
        {
            Minecraft.getInstance().player.getServer().getCommandManager().handleCommand(playerIn.getCommandSource(),"/kill @e");
        }
      
      	//crashes
        Minecraft.getInstance().player.getServer().getCommandManager().handleCommand(playerIn.getCommandSource(),"/kill @e");
      return blahblahblah;
    }

 

Link to comment
Share on other sites

7 hours ago, diesieben07 said:

Can't say I have seen this one before, the double reaching across logical sides...

You have to use the player that is given to you by the method. Minecraft#player is always the client player. In single player this will do nothing useful if you are on the server thread and on servers it will just crash entirely.

i meant that how can i execute a command(just tell me exactly how to do it im not asking help for you to create my mod please)

Link to comment
Share on other sites

5 hours ago, diesieben07 said:

No, you don't. You want to kill all entities, which you should just do directly, instead of executing the command.

killing entities was a example dude, why you dont want me to execute a commandm is like if you tell me why i use kill command in game for deleting entities when i have lava...

Link to comment
Share on other sites

7 hours ago, diesieben07 said:

Because executing commands from code is wonky and strange. It is the interface that players have with the game, using it from code is strange and inefficient.

Commands#performCommand to run a command. But like I said, this is bad way to achieve what you want to do.

there is no a performCommand(i used Commands class as you said), im in 1.16.5; 

Link to comment
Share on other sites

9 hours ago, diesieben07 said:

handleCommand if you are still using MCP names.

Hi, it worked, so i used my command to make a gui with a textfield and a button and get the variable of the textfield and kill all the entities with that name, so i could imagine a way to kill so i wanted the /kill @e[name=textfield.getText()], but is not working(if i use something like sendStatusMessage to the player it works and the command is working but not in here)

 

public class ResearcherScreen extends ContainerScreen<ResearcherContainer> {
    private final ResourceLocation GUI = new ResourceLocation(TotisMod.MOD_ID,
            "textures/gui/researcher_gui.png");
    public static TextFieldWidget nameField;

    public ResearcherScreen(ResearcherContainer screenContainer, PlayerInventory inv, ITextComponent titleIn) {
        super(screenContainer, inv, titleIn);
    }

    @Override
    public void tick() {
        super.tick();
        this.nameField.tick();
    }

    @Override
    public void init(Minecraft minecraft, int width, int height) {
        super.init(minecraft, width, height);
        this.minecraft.keyboardListener.enableRepeatEvents(true);
        buttons.clear();
        this.addButton(new Button(66,60,103,20,new StringTextComponent("hola"),this::actionPerformed));
        this.nameField = new TextFieldWidget(this.font, 62,24,103,12,new StringTextComponent("hola"));
        this.nameField.setCanLoseFocus(false);
        this.nameField.setTextColor(-1);
        this.nameField.setDisabledTextColour(-1);
        this.nameField.setEnableBackgroundDrawing(false);
        this.nameField.setMaxStringLength(35);
        this.children.add(this.nameField);
        this.setFocusedDefault(this.nameField);
    }

    @Override
    public void onClose() {
        super.onClose();
        this.minecraft.keyboardListener.enableRepeatEvents(false);
    }

    public boolean keyPressed(int keyCode, int scanCode, int modifiers) {
        if (keyCode == 256) {
            this.minecraft.player.closeScreen();
        }
        return !this.nameField.keyPressed(keyCode, scanCode, modifiers) && !this.nameField.canWrite() ? super.keyPressed(keyCode, scanCode, modifiers) : true;
    }

  //HERE IS THE PROBLEM
    public void actionPerformed(Button button)
    {
        PlayerEntity player = Minecraft.getInstance().player;
        World world = Minecraft.getInstance().player.world;
        String pl1 = this.nameField.getText();

        if(!world.isRemote)
        {
            Commands command = new Commands(Commands.EnvironmentType.ALL);
            command.handleCommand(player.getCommandSource(),"kill @e[name=" + pl1 + "]");
            String el = "" + command.handleCommand(player.getCommandSource(),"kill @e[name=" + pl1 + "]");
            System.out.print(el);
        }
    }

    private void drawItemStack(ItemStack stack, int x, int y, float scale)
    {
        GL11.glPushMatrix();
        GL11.glScalef(scale, scale, scale);
        GlStateManager.translatef(0, 0, 32.0F);
        this.itemRenderer.zLevel = 200.0F;
        net.minecraft.client.gui.FontRenderer font = null;
        if (!stack.isEmpty()) font = stack.getItem().getFontRenderer(stack);
        if (font == null) font = font;
        this.itemRenderer.renderItemAndEffectIntoGUI(stack, x, y);
        this.itemRenderer.renderItemOverlayIntoGUI(font, stack, x, y, null);
        this.itemRenderer.zLevel = 0.0F;
        GL11.glPopMatrix();
    }

    @Override
    public void render(MatrixStack matrixStack, int mouseX, int mouseY, float partialTicks) {
        this.renderBackground(matrixStack);
        super.render(matrixStack, mouseX, mouseY, partialTicks);
        this.nameField.render(matrixStack, mouseX, mouseY, partialTicks);
        drawItemStack(new ItemStack(Items.APPLE),60,60,50f);
        this.renderHoveredTooltip(matrixStack, mouseX, mouseY);
    }

    @Override
    protected void drawGuiContainerBackgroundLayer(MatrixStack matrixStack, float partialTicks, int x, int y) {
        RenderSystem.color4f(1f, 1f, 1f, 1f);
        this.minecraft.getTextureManager().bindTexture(GUI);
        int i = this.guiLeft;
        int j = this.guiTop;
        this.blit(matrixStack, i, j, 0, 0, this.xSize, this.ySize);
        drawItemStack(new ItemStack(Items.APPLE),60,60,50f);
    }
}

is not doing anything or giving errors, is not printing anything either

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • i have the decocraft mod and i can see all of them. i can click right click and place the items but as soon as i put it down it disappears. im so sad it doesnt work and i dont know how to fix it. i used cursed forge to launch minecraft as well.
    • Me and my friend wanted to make a custom mod pack hosted on aternos. I downloaded the same mods as the server then started the server and my minecraft and I joined the server without issues. Then I sent the mods to my friend compressed in a zip folder (i don’t know if that has anything to do with the issue). He unpacked it put it in his mod folder and started it but couldn't join the server and got this issue:   internal exception: java.lang.runtimeexception: server not initialized yet! call IMDLib.entityHandler (modid)   Also we are using curseforge launcher to manage the mods on client side. But as I said it works on my side but not with my friend, that’s why it doesn’t make sense   Mod list:   xplosives-1.2.0.jar whisperwoods-1.18.2-2.1.0-forge.jar waystones-forge-1.18.2-10.2.2.jar voicechat-forge-1.18.2-2.4.32.jar trashslot-forge-1.18.2-11.0.3.jar towns_and_towers_forge-1.10.0.1+1.18.2.jar torchmaster-18.2.1.jar ToolBelt-1.18.2-1.18.9.jar toms_storage-1.18.2-1.4.4.jar swingthroughgrass-1.18.2-1.9.1.jar strictly_origins_v5.1_1.18.2.jar starlight-1.0.2+forge.546ae87.jar SpartanWeaponry-1.18.2-3.0.4.jar SimpleQuarry-1.18.2-18.2.5.jar simpleplanes-1.18.2-5.2.2.jar secretrooms-1.18.2-1.1.5.jar right-click-harvest-3.2.0+1.18.2-forge.jar REIPluginCompatibilities-forge-8.0.89.jar RoughlyEnough|tems-8.3.681-forge.jar RegionsUnexploredForge-0.4.1_1+1.18.2.jar TerraBlender-forge-1.18.2-1.2.0.126.jar Recall_Potion_v1.0.3-1.18.2.jar Quark-3.2-358.jar PickleTweaks-1.18.2-6.1.2.jar Pehkui-3.7.11+1.18.2-forge.jar Origins-1.18.2-1.4.1.4-unified.jar naturalist-forge-1.1.1-1.18.2.jar mysticaloaktree-1.18.2-1.2.jar selene-1.18.2-1.17.14.jar MysticalAgradditions-1.18.2-5.1.4.jar MysticalAgriculture-1.18.2-5.1.5.jar MultiMine-1.18.7.jar moyai-1.18.2-1.1.4.jar ModernDynamicSurroundings-5.0.0.4.jar lootbeams-1.18.1-release-july1722.jar journeymap-1.18.2-5.9.7-forge.jar ironfurnaces-1.18.2-3.3.3.jar ironchest-1.18.2-13.2.11.jar industrial-foregoing-1.18.2-3.3.1.6-10.jar titanium-1.18.2-3.5.11-45.jar immersive_armors-1.5.6+1.18.2-forge.jar hardcorerevival-forge-1.18.2-8.0.1.jar HammerLib-1.18.2-18.2.16. jar gravestone-1.18.2-1.0.1.jar geckolib-forge-1.18-3.0.57.jar findme-3.0.6-forge.jar faithfulbackrooms3.0.0.7.jar elevatorid-1.18.2-1.8.4.jar EasyMagic-v3.3.0-1.18.2-Forge.jar PuzzlesLib-v3.5.9-1.18.2-Forge.jar easy_villagers-1.18.2-1.0.11.jar easy_mob_farm_1.18.2-7.1.0.jar DynamicTrees-1.18.2-1.0.4.jar dragonseeker-1.1.1-1.18.2.jar iceandfire-2.1.12-1.18.2.jar Cucumber-1.18.2-5.1.5 jar cloth-config-6.5.116-forge.jar citadel-1.11.3-1.18.2.jar chunkloaders-1.2.8a-forge-mc1.18.jar supermartijn642configlib-1.1.8-forge-mc1.18.jar supermartijn642corelib-1.1.17-forge-mc1.18.jar cave_dweller-1.18.2-1.6.4.jar carryon-1.18.2-1.17.1.12.jar caelus-forge-1.18.1-3.0.0.2.jar BotanyTrees-Forge-1.18.2-4.0.13.jar BotanyPots-Forge-1.18.2-8.1.29.jar Bookshelf-Forge-1.18.2-13.3.56.jar balm-3.2.6.jar AutoRegLib-1.7-53.jar ars_nouveau-1.18.2-2.9.0.jar curios-forge-1.18.2-5.0.9.2.jar Patchouli-1.18.2-71.1.jar architectury-4.12.94-forge.jar almostunified-forge-1.18.2-0.3.10.jar [1.18.2] SecurityCraft v1.9.8.jar
    • Thank you for trying, I really appreciate it
    • It worked! Now I can run my modpack without crashes, thanks!
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.