Jump to content

Interface method implemented in superclass not working after reobfuscation


gcewing
 Share

Recommended Posts

I have a class implementing IInventory that relies on a superclass to provide implementations for its methods. There's a message here https://github.com/BuildCraft/BuildCraft/pull/726 mentioning that this won't work unless you use reobfuscate_srg.sh instead of reobfuscate.sh.

 

However, I am using reobfuscate_srg.sh, and it still doesn't work. I get:

 

2013-07-28 19:24:23 [iNFO] [sTDOUT] java.lang.AbstractMethodError
2013-07-28 19:24:23 [iNFO] [sTDOUT] 	at net.minecraft.inventory.Slot.func_75211_c(Slot.java:91)

 

where that line is doing

 

return this.inventory.getStackInSlot(this.slotIndex);

 

It works unobfuscated, but not obfuscated. I'm using Forge 9.10.0.789.

 

Anyone have any ideas?

Link to comment
Share on other sites

i tried recreating the error, but i didn't get any. but then i didn't really try too hard and i'm using 9.10.0.800. maybe try updating? or maybe try explicitly implementing it in the subclass as well and then just call the super in each method and see if that works

 

edit: misunderstood your post. my new answer: i have no idea. but why not just implement it in your superclass as well? (does that question make sense or did i misunderstand again?)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.