Jump to content

"Could not find or load main class @user_jvm_args.txt" when launching forge server.


gandaalv

Recommended Posts

  • OS: Ubuntu 20.04
  • Java: openjdk-17-jre
  • Error message: Could not find or load main class @user_jvm_args.txt

 

Hey, my forge server wont launch anymore through the run.sh script after a sudden rootserver outage and reboot.

I tried force-reinstalling the openjdk but that didn't seem to solve the issue. Any suggestions on how to get the forge server back running?

Link to comment
Share on other sites

3 minutes ago, diesieben07 said:

That error message is indicate of a wrong Java version. Java 17 is needed for 1.18.

Just to clear that up, the forge server was running fine for days until that outage happend.

Printing java -version outputs:

openjdk version "1.8.0_312"
OpenJDK Runtime Environment (build 1.8.0_312-8u312-b07-0ubuntu1~20.04-b07)
OpenJDK 64-Bit Server VM (build 25.312-b07, mixed mode)

 

Link to comment
Share on other sites

6 minutes ago, diesieben07 said:

Well, Java 17 is required for 1.18.

Not the type of help i expected but installing the oracle-java17-installer and oracle-java17-set-default packages solved the issue. Still doesn't explain why it worked before with the openjdk.

Link to comment
Share on other sites

  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.