Jump to content

Stuck on trying to carry a capability after death


Recommended Posts

I'm trying to store the players inventory so that they will keep it after dying if they are holding a specific item, I made a capability extending IItemHandler and ItemStackHandler to hold it which I attached to the players and I've been testing it's functions and it seems to store everything correctly, but no matter what I try, after respawing it's back to being empty and no items were copied

Here's my most resent try:

@Mod.EventBusSubscriber(modid = ExtraTotems.MOD_ID, bus = Mod.EventBusSubscriber.Bus.FORGE)
public class CommonEvents {

    public static void onEntityDeath(LivingDeathEvent event){
        LivingEntity entity = event.getEntityLiving();
        if(entity instanceof Player player && !event.getSource().isBypassInvul() && checkTotemInventoryProtection(event)){ //last function checks if the totem was in one of the players hands
            player.getCapability(Capabilities.EXTRA_ITEM_HANDLER_CAPABILITY).resolve().ifPresent(deathInventory ->
                    deathInventory.copyInventory(player.getInventory())); //copies the inventory before death to the capability
        //... some extra unrelated stuff


    public static void onPlayerClone(PlayerEvent.Clone event){
        if(event.isWasDeath()) {
            Player originalPlayer = event.getOriginal();
          	Player newPlayer = event.getPlayer();
            int MAIN_HAND = originalPlayer.getInventory().selected;
            int OFF_HAND = 40;

            originalPlayer.getCapability(Capabilities.EXTRA_ITEM_HANDLER_CAPABILITY).resolve().ifPresent(deathInventory ->
                    newPlayer.getCapability(Capabilities.EXTRA_ITEM_HANDLER_CAPABILITY).resolve().ifPresent(newInventory -> {
                        int totemSlot = (deathInventory.getStackInSlot(MAIN_HAND).is(ModItems.TOTEM_OF_KEEPING) ? MAIN_HAND : OFF_HAND); //saves the slot number where the item was held
                        Inventory inv = new Inventory(newPlayer);
                        for (int i = 0; i < 41; ++i) {
                            if (i == totemSlot) continue; //avoids copying the item to have it destroyed
                            inv.setItem(i, deathInventory.getStackInSlot(i));
                        newInventory.copyInventory(inv); //before I was doing a method where I was trying to directly copy what's in deathInventory to newInventory (not creating an actual inventory in the middle) but it wasn't working
    public static void onPlayerRespawn(PlayerEvent.PlayerRespawnEvent event){
            Player player = event.getPlayer();
            player.getCapability(Capabilities.EXTRA_ITEM_HANDLER_CAPABILITY).resolve().ifPresent(deathInventory -> {
                for (int i = 0; i < 41; i++){
                    player.getInventory().setItem(i, deathInventory.getStackInSlot(i));
        } //also tried just doing this directly on onPlayerClone instead of copying the capability (the idea being the new copy wouldn't get a copy of the capability, just get the inventory), neither seem to work


Am I missing something obvious?

Link to comment
Share on other sites

I use .ifPresent always just because IntelliJ bugs you if you just use .get without .isPresent (and ifPresent is just like both of them in one)

Copying the stacks directly during PlayerEvent.Clone is what I thought would work in the beginning as well, but it seems the original copy just has an empty inventory, even if the LivingDropsEvent was canceled, that's why I started looking into capabilities

I thought about looking at the KEEPINVENTORY rule, but I absolutely don't understand where it is, it's regitered in the GameRules class but it's just a boolean, I'm sure there is a check for it somewhere, but IntelliJ finds no usages of the variable and I couldn't find it manually

Edited by Whistler
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hi everyone  I'm trying to make a custom door and give it a custom sound. In order to do so I've registered the sounds like this   private static final DeferredRegister<SoundEvent> SOUNDS = DeferredRegister.create(ForgeRegistries.SOUND_EVENTS, MineWorld.MOD_ID); ... public static final RegistryObject<SoundEvent> SCULK_DOOR_CLOSE = SOUNDS.register("sculk_door_close", () -> SoundEvent.createVariableRangeEvent(new ResourceLocation(MineWorld.MOD_ID, "sculk_door_close"))); public static final RegistryObject<SoundEvent> SCULK_DOOR_OPEN = SOUNDS.register("sculk_door_open", () -> SoundEvent.createVariableRangeEvent(new ResourceLocation(MineWorld.MOD_ID, "sculk_door_open"))); call the register method of the Sounds registry as the first thing in my mod initialize method IEventBus eventBus = FMLJavaModLoadingContext.get().getModEventBus(); SOUNDS.register(eventBus); Then I create a BlockSetType like this   public static final BlockSetType SCULK = BlockSetType.register(new BlockSetType(new ResourceLocation(MineWorld.MOD_ID, "sculk").toString(), true, SoundType.WOOD, SCULK_DOOR_CLOSE.get(), SCULK_DOOR_OPEN.get(), SoundEvents.WOODEN_TRAPDOOR_CLOSE, SoundEvents.WOODEN_TRAPDOOR_OPEN, SoundEvents.WOODEN_PRESSURE_PLATE_CLICK_OFF, SoundEvents.WOODEN_PRESSURE_PLATE_CLICK_ON, SoundEvents.WOODEN_BUTTON_CLICK_OFF, SoundEvents.WOODEN_BUTTON_CLICK_ON); And finally the door block like this private static final DeferredRegister<Block> BLOCKS = DeferredRegister.create(ForgeRegistries.BLOCKS, MineWorld.MOD_ID); ... BLOCKS.register("sculk_door", () -> new DoorBlock(BlockBehaviour.Properties.copy(Blocks.OAK_DOOR), blockSetType)); But when I launch the game I get this error   Registry Object not present: mineworld:sculk_door_close Am I doing something wrong? Maybe the BlockSetType registration needs to be done in a different way? I have other BlockSetTypes registered like this that only uses vanilla sounds and they work just fine. You can see an example in my GitHub repo here: https://github.com/JimiIT92/MineWorld/blob/master/src/main/java/org/mineworld/core/MWBlockSetTypes.java
    • it was eldritch end, thank you
    • Okay. Thank you. I think it works now. I added the jdk-17 path to the batch instead of the jvm arguments txt file. The windows command prompt is just blank, but when I close the native windows command prompt, the java command prompt opens & loads the server. If that won't cause issues then I'm all good. 
    • I have no idea - the last mentioned mods are eldritch_end, supplementaries and mahoutsukai Start with removing mahoutsukai
  • Topics

  • Who's Online (See full list)

    • There are no registered users currently online
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.