Jump to content

Ubuntu: Failed to download version manifest, can not find server jar URL.

Recommended Posts

Hey so I am very new to Linux as a whole, I have a computer that I am turning into a Minecraft server, and I wanted to get experience with Linux, as I have never truly used it, I am using the Ubuntu kernel and following guides for everything. I am following this guide on YouTube linked here:

and I have followed the setup this guy has ex: /Documents/Server/Attempt1 (I replaced the server name found in the video) I have fully updated java to:

"java version "17.0.1" 2021-10-19 LTS
Java(TM) SE Runtime Environment (build 17.0.1+12-LTS-39)
Java HotSpot(TM) 64-Bit Server VM (build 17.0.1+12-LTS-39, mixed mode, sharing)"

I have in my Attempt1 folder the Forge installer: "forge-1.18.2-40.1.31-installer.jar" and that is it.

I use the command "java -jar forge-1.18.2-40.1.31-installer.jar" and then it loads up the installer, since I am wanting to download a server, not a client, I choose the server option, however I route the path of the server to the /Documents/Server/Attempt1 folder, and then I am given the error message: "Failed to download version manifest, can not find server jar URL." I have hit a wall at this point, and looked at other forums and have found nothing useful to me. Does anyone know what kind of jar URL I need? I thought the forge installer.jar would be the one it is looking for, but it appears not? If anyone is able to help, that would be greatly appreciated, and if you need anymore information or screenshots, I will provide them, however I might need instruction to ensure I send it the right way. Thank you again for your help!

Link to comment
Share on other sites

Well if it is, I think it could be because I haven't actually proceeded with the installer, so the server never officially started, because according to the video, it looks like after it starts, the installer populates the folder with the logs, and everything else with the server, which is not shown. But I don't think that should be the issue, would it? I saw in W2QGAMER's post his installer log, so I at least know what it looks like, but I don't have anything like that.

Link to comment
Share on other sites

I'm not quite sure this is what you were asking, I ran the code through the console, tried to do what I had done at the beginning of this forum, and copy and pasted the code here: "

java.io.FileNotFoundException: forge-1.18.2-40.1.31-installer.jar.log (Permission denied)
    at java.base/java.io.FileOutputStream.open0(Native Method)
    at java.base/java.io.FileOutputStream.open(FileOutputStream.java:293)
    at java.base/java.io.FileOutputStream.<init>(FileOutputStream.java:235)
    at java.base/java.io.FileOutputStream.<init>(FileOutputStream.java:184)
    at net.minecraftforge.installer.SimpleInstaller.getLog(SimpleInstaller.java:188)
    at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:55)
JVM info: Oracle Corporation - 17.0.1 - 17.0.1+12-LTS-39
Found java version 17.0.1
<html><a href='https://files.minecraftforge.net/'>Data kindly mirrored by Forge</a></html>
Considering minecraft server jar
java.nio.file.AccessDeniedException: /home/turbosnightmare/Documents/Server/Attempt1/1.18.2.json
    at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:90)
    at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:106)
    at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
    at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:219)
    at java.base/java.nio.file.spi.FileSystemProvider.newOutputStream(FileSystemProvider.java:484)
    at java.base/java.nio.file.Files.newOutputStream(Files.java:228)
    at java.base/java.nio.file.Files.copy(Files.java:3160)
    at net.minecraftforge.installer.DownloadUtils.downloadFile(DownloadUtils.java:323)
    at net.minecraftforge.installer.json.Util.getVanillaVersion(Util.java:79)
    at net.minecraftforge.installer.actions.ServerInstall.run(ServerInstall.java:86)
    at net.minecraftforge.installer.InstallerPanel.run(InstallerPanel.java:423)
    at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:175)
    at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:147)
Failed to download version manifest, can not find server jar URL."


Is this what you were looking for?

Link to comment
Share on other sites

Alright, i think that fixed the problem, I was able to use the sudo command and I was then able to browse through the files to the Attempt1 file and then I was able to install the server. First off, thank you for your help, it has been so nice to have instant replies, which I was not expecting, and this experience like everything else is helping me learn more about linux and computers as a whole. Second, is there anything that I need to know before I begin trying to find mods and downloading them, any guides or other forums that would help?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.