Jump to content

FML doesn't load when running mod in eclipse


SharkyGAMER

Recommended Posts

I get the following error every-time I try to run my mod in eclipse.

Aug 11, 2013 8:03:20 AM net.minecraft.launchwrapper.LogWrapper log

INFO: Using tweak class name cpw.mods.fml.common.launcher.FMLTweaker

2013-08-11 08:03:20 [iNFO] [ForgeModLoader] Forge Mod Loader version 6.2.43.819 for Minecraft 1.6.2 loading

2013-08-11 08:03:20 [iNFO] [ForgeModLoader] Java is Java HotSpot 64-Bit Server VM, version 1.6.0_51, running on Mac OS X:x86_64:10.8.4, installed at /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

2013-08-11 08:03:20 [iNFO] [ForgeModLoader] Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation

2013-08-11 08:03:20 [iNFO] [sTDOUT] Loaded 39 rules from AccessTransformer config file fml_at.cfg

2013-08-11 08:03:20 [iNFO] [sTDOUT] Loaded 107 rules from AccessTransformer config file forge_at.cfg

2013-08-11 08:03:20 [sEVERE] [ForgeModLoader] Unable to launch

java.lang.RuntimeException: java.lang.NullPointerException

at cpw.mods.fml.relauncher.CoreModManager.injectTransformers(CoreModManager.java:402)

at cpw.mods.fml.relauncher.FMLLaunchHandler.injectPostfixTransformers(FMLLaunchHandler.java:108)

at cpw.mods.fml.relauncher.FMLLaunchHandler.appendCoreMods(FMLLaunchHandler.java:113)

at cpw.mods.fml.common.launcher.FMLTweaker.injectIntoClassLoader(FMLTweaker.java:78)

at net.minecraft.launchwrapper.Launch.launch(Launch.java:51)

at net.minecraft.launchwrapper.Launch.main(Launch.java:18)

Caused by: java.lang.NullPointerException

at LZMA.LzmaInputStream.readHeader(LzmaInputStream.java:246)

at LZMA.LzmaInputStream.<init>(LzmaInputStream.java:65)

at cpw.mods.fml.common.asm.transformers.deobf.LZMAInputSupplier.getInput(LZMAInputSupplier.java:35)

at cpw.mods.fml.common.asm.transformers.deobf.LZMAInputSupplier.getInput(LZMAInputSupplier.java:1)

at com.google.common.io.ByteStreams$6.openStream(ByteStreams.java:989)

at com.google.common.io.ByteSource$AsCharSource.openStream(ByteSource.java:287)

at com.google.common.io.CharStreams$3.getInput(CharStreams.java:508)

at com.google.common.io.CharStreams$3.getInput(CharStreams.java:505)

at com.google.common.io.CharStreams.readLines(CharStreams.java:319)

at cpw.mods.fml.common.asm.transformers.deobf.FMLDeobfuscatingRemapper.setup(FMLDeobfuscatingRemapper.java:136)

at cpw.mods.fml.common.asm.FMLSanityChecker.injectData(FMLSanityChecker.java:226)

at cpw.mods.fml.relauncher.CoreModManager.injectTransformers(CoreModManager.java:397)

... 5 more

 

I have tried recompiling, decompiling, updating mcp and forge and switching version several times. None have worked. Minecraft will run fine through the launcher and it's using the same version.

 

I am new to java and don't have much experience with it. I would guess the error is to do with LMZA files, but I don't know how to fix.

 

Thank you for reading answer as soon as possible because I'm going on holiday tomorrow.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.