Jump to content

[Solved] Custom BlockFenceGate won't make open/close sounds


ozBillo

Recommended Posts

If the gate is closed and the player is holding a valid key, the gate opens.

If the gate is open and the player is not holding a valid key, the gate closes.

 

I use the playAuxSFXAtEntity method to play the appropriate sound on gate open and close.

But, I'm not getting any sound from the gate.

Other gates sound okay.

 

Here is the relevant code. Have I missed something?

 

public class MyGate extends BlockFenceGate {
...
@Override
public void onEntityCollidedWithBlock(World par1World, int par2, int par3, int par4, Entity par5Entity) {
	if(!par1World.isRemote) {
		if (par5Entity instanceof EntityLivingBase) {
        	EntityLivingBase entityLiving = (EntityLivingBase) par5Entity;
        	if (entityLiving instanceof EntityPlayer) {
        		EntityPlayer entityPlayer = (EntityPlayer) entityLiving;        		
...
        		int i1 = par1World.getBlockMetadata(par2, par3, par4);
        		boolean MyGateOpen = isFenceGateOpen(i1);
        		
			if (!MyGateOpen && holdingValidKey) {
				MyGateOpen = true;
				par1World.setBlockMetadataWithNotify(par2, par3, par4, i1 | 4, 2); // open the gate
				par1World.playAuxSFXAtEntity(entityPlayer, 1003, par2, par3, par4, 0);
			} 
			else if (MyGateOpen && !holdingValidKey) {
				MyGateOpen = false;
				par1World.setBlockMetadataWithNotify(par2, par3, par4, i1 & -5, 2); // close the gate
				par1World.playAuxSFXAtEntity(entityPlayer, 1003, par2, par3, par4, 0);
			}

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Remove these mods and combine OptiFine HD U I6 with Forge 47.2.18 Start with Optifine - without any other mods - if this works, add the mods one by one or in groups until you find the mod, conflicting with Optifine
    • Ok yeah I think this might be where the problem starts. For starters, I think you can get rid of your RecipeType impl and make it a static constant instead. I'm not 100% sure this will fix it but it's posssible. RuneInscribingRecipe public class RuneInscribingRecipe implements Recipe<SimpleContainer> { public static final RecipeType<RuneInscribingRecipe> RECIPE_TYPE = new RecipeType<>(){}; // .... @Override public RecipeType<?> getType() { return RECIPE_TYPE; } // .... } RuneInscriberMenu private Optional<RecipeHolder<RuneInscribingRecipe>> getCurrentRecipe() { SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); List<RecipeHolder<RuneInscribingRecipe>> list = this.blockEntity.getLevel().getRecipeManager().getRecipesFor(RuneInscribingRecipe.RECIPE_TYPE, inventory, this.blockEntity.getLevel()); if (list.isEmpty()) { return Optional.empty(); } return Optional.of(list.get(0)); }   Also, this here is a little suspicious where you're getting the `this.inventory.getStackInSlot` calls. I'd try and make sure those are what you expect they are with either a Debug line in IDE or print statement SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); System.out.printf("CHECKING BASE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); System.out.printf("CHECKING TEMPLATE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); ^ See what the result of those print statements are, make sure they're right
    • Upon testing again after adding them, the game still doesn't crash however the resource packs are still unfortunately broken.
    • Hi! Can someone please point me to the correct FAQ or place? I'm not able do DuckDuckGo myself out of this one. As you can hopefully see, chunks are not rendered. I run a forge server, fresh install on a linux VM. Curseforge on the Win11 client with Embeddium, Oculus and Unbound shader. No mods. Forge 47.2.23 on server & client.  No errors, no crashes, no apparent CPU or RAM issues with the VM. This screenshot was captured while creative, but the same happens when flying in survival. Waiting (floating) for a few minutes sooner or (often) later, lets the missing chunks appear. Usually takes 5-10 minutes.  When on a local game, the chunks appear slowly, but they do appear without pause.   This must be something simple, obvious, but I can't find the correct "search words" to find my way out. "Chunks not loading / rendering" didn't help. Browsing several forums neither. 
    • This is the Forge forums. We only support Forge here. Read the FAQ
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.