Jump to content

Forge libraries failed to download


Recommended Posts

I tried downloading forge for different versions of Minecraft and none of the older version are working so I tried downloading forge for 1.19.2 to see if maybe the older versions just aren't supported anymore but I got an error again. I did a fresh install of Minecraft and Java and restarted my PC after installing both but nothing is working. I can download Optifine though but not forge.

These libraries failed to download. Try again.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.