Jump to content

Integrating With Other Mods [Latest Forge - Minecraft 1.19]

Monadic Cat

Recommended Posts


I was working on my first mod recently, and needed to detect another one (CC: Tweaked) for the purpose of loading optional integration with it.

I only encountered threads on this forum which were very old and used an API which no longer exists in Forge to accomplish this.

So, for posterity, the correct thing to use to detect another mod is: ModList.get().isLoaded("mod_id_goes_here")

ModList is a class in the net.minecraftforge.fml package, and can be imported like: import net.minecraftforge.fml.ModList;



To actually integrate with another mod, it seems like you'll want to run some code which uses classes from the other mod.

To do this without introducing a hard dependency on that mod (i.e., to retain the ability to run without it being there), you need to split the code which requires it out into its own class, and then load that class using Class.forName("YourClass") and avoid directly using that class. Instead, dynamically lookup the entry point method for your integration with something like your_class.getDeclaredMethod("yourEntryPoint") and invoke it with invoke.

A complete loading side example might look something like:

import net.minecraftforge.fml.ModList;
import java.lang.reflect.InvocationTargetException;

if (ModList.get().isLoaded("other_mod_id")) {
  try {
    var yourClass = Class.forName("YourIntegrationClass");
    var yourMethod = yourClass.getDeclaredMethod("loadIntegration");
    yourMethod.invoke(null, new Object[0]);
  } catch (ClassNotFoundException e) {
    // fail out in your preferred way, for the case where the integration class somehow isn't in your mod jar
  } catch (NoSuchMethodException e) {
    // fail out in your preferred way, for the case where the method named here doesn't exist. possibly a typo on your part.
  } catch (InvocationTargetException e) {
    // fail out in your preferred way, for the case where the method called throws its own exception
  // okay, I didn't feel like listing all of the failure cases out like that.
  // there are additional exceptions to handle here. not all are mandatory, but here's the remaining as an unordered list:
  // - LinkageError
  // - ExceptionInInitializerError
  // - NullPointerException
  // - SecurityException
  // - IllegalAccessException
  // - IllegalArgumentException


  • Like 1
Link to comment
Share on other sites

A better way to do this is just to have the plugin code be in a separate class and just calling a method in that class which initializes the data. Java classes are lazily loaded, so you don't need to do invoke logic at all.

public void ExampleMod() {
    if (ModList.get().isLoaded("other_mod_id")) {
        // Won't be called or initialized unless the mod is present.
        // This is exactly how we protect from sidedness as well


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I have a structure, and sometimes several mobs spawn there. This is a boss and must spawn alone. Here is the code for spawning entities in the structure { "type": "minecraft:jigsaw", "start_pool": "egyptcraft:boss_pyramid/start_pool", "size": 5, "max_distance_from_center": 80, "biomes": "#egyptcraft:has_structure/boss_pyramid", "step": "surface_structures", "start_height": { "absolute": 0 }, "project_start_to_heightmap": "WORLD_SURFACE_WG", "use_expansion_hack": false, "spawn_overrides": { "monster": { "bounding_box": "full", "spawns": [ { "type": "egyptcraft:anubis", "maxCount": 1, "minCount": 1, "weight": 100 } ] } } } Maybe it's something else?
    • I have OreGenEvent.GenerateMinable event, I need to get a chance to spawn (generate) every ore that is processed in this event. Also e.getType().name().toString() is name this is the same block name by which it can be entered in the Block.getByID?  forge 1.12.2 59(recommended)
    • Hello everybody! Out of nowhere my minecraft doesn't allow me to play on forge 1.19.2 I tried to reinstall minecraft, doesn't have any mod right now on the forge version. Tried the newest version of forge, tried recommended version as well. I have the newest version of Java as well...   I dont know why it stopped working but it just stopped completly out of nowhere...   Thank you so much for your help guys ❤️
    • Hello, my world is crashing at 0% loaded and I don't know why. (Forge 43.2.14, 1.19.2) I have two worlds that I play on, and one works and the other doesn't, even with the same mod list. Here's the crash report: https://pastebin.com/AUbRwkGj
    • Minecraft 1.12.2 Very frustrating error. only ever occurs on one device. Started yesterday without prompting (maybe java updated or something?) Says things that have been imported actually arent when running client Reinstalled Intellij, cleared cache, cleaned and rebuilt gradle, redownloaded the entire file from git. Nothing works. (I believe I have the right plugins installed, dependencies OK, and am using corretto 1.8).   One thing I did for more of the below errors was just to explicitly import them, which was working up until this little guy who literally does not exist in forge to import. the class inhereting something inhereting it refers to import net.minecraftforge.registries.IForgeRegistryEntry.Impl, not net.minecraftforge.registries.IForgeRegistryEntry$Impl as the output implies. also I didn't even have to manually import these things for it to work on my other device. (which is just importing the minecraft package that contains them), but here I did have to just to get rid of a few errors--not even make anything work?? I dont know. (edited) here's the aforementioned "below error" (one of many like it): error: cannot access net.minecraftforge.registries.IForgeRegistryEntry.Impl public class BlockBase extends Block {        ^   class file for net.minecraftforge.registries.IForgeRegistryEntry$Impl not found Here's the class BlockBase:   package com.quantum.exodus.common.blocks; import com.quantum.exodus.ExodusMod; import net.minecraft.block.Block; import net.minecraft.block.material.Material; import net.minecraft.creativetab.CreativeTabs; import net.minecraft.item.Item; import net.minecraft.item.ItemBlock; import net.minecraftforge.registries.IForgeRegistryEntry.Impl; public class BlockBase extends Block { protected String name; public BlockBase(Material material, String name) { super(material); this.name = name; setTranslationKey(name); setRegistryName(name); } public void registerItemModel(Item itemBlock) { ExodusMod.proxy.registerItemRenderer(itemBlock, 0, name); } public Item createItemBlock() { return new ItemBlock(this).setRegistryName(getRegistryName()); } @Override public BlockBase setCreativeTab(CreativeTabs tab) { super.setCreativeTab(tab); return this; } }
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.