Jump to content

Using IExtendedEntityProperties on multiplayer


Briggybros

Recommended Posts

Hello, I'm trying to use a class that implements IExtendedEntityProperties to add a currency to the player. I initialize the class when the player entity is constructed like so:

@ForgeSubscribe(priority = EventPriority.NORMAL)
public void onEntityConstuct(EntityConstructing event) {
	if (event.entity instanceof EntityPlayerMP) {
		EntityPlayerMP ep = (EntityPlayerMP) event.entity;
		ep.registerExtendedProperties(PlayerProperties.IDENTIFIER, new PlayerProperties());
	}
}

 

The PlayerProperties class looks like so:

public class PlayerProperties implements IExtendedEntityProperties {

public static final String IDENTIFIER = "playerproperties";

public static PlayerProperties fromPlayer(EntityPlayerMP player) {
	return (PlayerProperties) player.getExtendedProperties(IDENTIFIER);
}

int credits = 0;

EntityPlayerMP player;

@Override
public void saveNBTData(NBTTagCompound compound) {
	compound.setInteger("credits", credits);
}

@Override
public void loadNBTData(NBTTagCompound compound) {
	if (compound.hasKey("credits")) {
		this.credits = compound.getInteger("credits");
	} else {
		this.credits = 30;
	}
	sendPacket();
}

@Override
public void init(Entity entity, World world) {
	player = (EntityPlayerMP) entity;
}

private void sendPacket() {
	PacketDispatcher.sendPacketToPlayer(new PropertiesPacket(credits).makePacket(), (Player) player);
}
}

 

Where my PropertiesPacket class looks like so:

public class PropertiesPacket extends BasePacket {

int credits;

public PropertiesPacket(int credits) {
	this.credits = credits;
}

public PropertiesPacket() {

}

@Override
public void write(ByteArrayDataOutput out) {
	out.writeInt(credits);
}

@Override
public void read(ByteArrayDataInput in) {
	credits = in.readInt();
}

@Override
public void execute(EntityPlayer player, Side side) {
	if (side.isClient()) {
		PlayerData.credits = credits; // PlayerData is just a static client side class which stores the data.
	}
}

}

 

Where the BasePacket class looks like this:

public abstract class BasePacket {

public static final String CHANNEL = "MyPacket";
private static final BiMap<Integer, Class<? extends BasePacket>> idMap;

static {
	ImmutableBiMap.Builder<Integer, Class<? extends BasePacket>> builder = ImmutableBiMap.builder();

	builder.put(Integer.valueOf(0), PropertiesPacket.class);

	idMap = builder.build();
}

public static BasePacket constructPacket(int packetId) throws ProtocolException, ReflectiveOperationException {
	Class<? extends BasePacket> clazz = idMap.get(Integer.valueOf(packetId));
	if (clazz == null) {
		throw new ProtocolException("Unknown Packet Id!");
	} else {
		return clazz.newInstance();
	}
}

public static class ProtocolException extends Exception {

	public ProtocolException() {
	}

	public ProtocolException(String message, Throwable cause) {
		super(message, cause);
	}

	public ProtocolException(String message) {
		super(message);
	}

	public ProtocolException(Throwable cause) {
		super(cause);
	}
}

public final int getPacketId() {
	if (idMap.inverse().containsKey(getClass())) {
		return idMap.inverse().get(getClass()).intValue();
	} else {
		throw new RuntimeException("Packet " + getClass().getSimpleName() + " is missing a mapping!");
	}
}

public final Packet makePacket() {
	ByteArrayDataOutput out = ByteStreams.newDataOutput();
	out.writeByte(getPacketId());
	write(out);
	return PacketDispatcher.getPacket(CHANNEL, out.toByteArray());
}

public abstract void write(ByteArrayDataOutput out);

public abstract void read(ByteArrayDataInput in);

public abstract void execute(EntityPlayer player, Side side);
}

 

and my packet handler is as so:

public class PacketHandler implements IPacketHandler {

@Override
public void onPacketData(INetworkManager manager, Packet250CustomPayload packet, Player player) {
	try {
		EntityPlayer entityPlayer = (EntityPlayer) player;
		ByteArrayDataInput in = ByteStreams.newDataInput(packet.data);
		int packetId = in.readUnsignedByte();
		BasePacket basePacket = BasePacket.constructPacket(packetId);
		basePacket.read(in);
		basePacket.execute(entityPlayer, entityPlayer.worldObj.isRemote ? Side.CLIENT : Side.SERVER);
	} catch (ProtocolException e) {
		if (player instanceof EntityPlayerMP) {
			((EntityPlayerMP) player).playerNetServerHandler.kickPlayerFromServer("Protocol Exception!");
			Logger.getLogger("DemoMod").warning("Player " + ((EntityPlayer) player).username + " caused a Protocol Exception!");
		}
	} catch (ReflectiveOperationException e) {
		throw new RuntimeException("Unexpected Reflection exception during Packet construction!", e);
	}
}
}

However, when this code is run, it throws a null pointer exception and the packet isn't sent. Every time I've used this method of sending packets previously it's worked a charm, but this time it doesn't.

 

The stack trace is:

2013-09-11 21:30:37 [iNFO] [sTDERR] java.lang.NullPointerException
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at cpw.mods.fml.common.network.PacketDispatcher.sendPacketToPlayer(PacketDispatcher.java:45)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at mods.SaberMod.SaberValues.sendPacket(SaberValues.java:147)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at mods.SaberMod.SaberValues.loadNBTData(SaberValues.java:76)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.entity.Entity.readFromNBT(Entity.java:1647)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.server.management.ServerConfigurationManager.readPlayerDataFromFile(ServerConfigurationManager.java:239)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.server.management.ServerConfigurationManager.initializeConnectionToPlayer(ServerConfigurationManager.java:113)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.server.integrated.IntegratedServerListenThread.networkTick(IntegratedServerListenThread.java:97)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.server.MinecraftServer.updateTimeLightAndEntities(MinecraftServer.java:689)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.server.MinecraftServer.tick(MinecraftServer.java:585)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.server.integrated.IntegratedServer.tick(IntegratedServer.java:129)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:482)
2013-09-11 21:30:37 [iNFO] [sTDERR] 	at net.minecraft.server.ThreadMinecraftServer.run(ThreadMinecraftServer.java:16)

 

which points to this line in the packet dispatcher:

public static void sendPacketToPlayer(Packet packet, Player player)
    {
        if (player instanceof EntityPlayerMP)
        {
            ((EntityPlayerMP)player).playerNetServerHandler.sendPacketToPlayer(packet); //<-- this one
        }
    }

This suggests the player in its own variables is wrong, the player's missing the server handler or the packet is null. I'm assuming the packet is null, but I don't see why this one shouldn't work while the others do. What is the likely problem here?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hi I have an issue with a server it solved deleting the ice and fire but my friends and me really want to use it does any of these mods are causing the issue due to incompatibility  Security craft Aquaculture Architectury Artifacts Astikorcarts Baubles BetterCaves yungs BetterStrongholds yungs BetterMineshafts yungs Bountiful Byg  Callablehorses Carry on Chococraft Citadel Clumps Collective Comforts Corailrecycler Craftable horse armor Comes alive Curios forge Decocraft Dungeonsarise  Open blocks elevator Expandability Farlanders Goblin traders Hwyla  Ice and fire Infernal expansion Jei Jump over fences Mantle  Macaws bridges Macaws doors Macaws fences Macaws furniture  Macaws fencesbyg Morpheus Mouse tweaks Mowzies mobs Obfuscate Paraglider Patchouli  Pick up notifier Random village names Spartan shields Small ships Sophisticated backpacks Spartan weaponry Storage drawers straw golem Structure gel Twilight forest  Tinkers construct Two players one horse  Valhesia core  Valhesia structures  Way stones  Vehicle mod  Wall jump Wings Wolves with armor Xptome  Xaeros minimap  Yungsapi  
    • { "type": "magic_overhaul:rune_inscribing", "base": { "item": "//base item" }, "template": { "item": "//template item" }, "output": { "count": 1, "item": "//output item" } } ^ Ok, where is your recipe JSON placed in your file structure? What's it called? And paste the actual JSON you're testing with, because it needs to be valid.
    • I'm trying to run Forge 1.12.2 on Minecraft  so I can use certain mods, but this error popped up. I've seen multiple errors but I just can't figure this one out. Unable to locate the Java runtime. Error details: 0x00000000 - system: The operation completed successfully. Filename on disk:  Path: . Exists: Directory
    • https://mclo.gs/b422RFc
    • Плагин и Приват
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.