Jump to content

Alpine running Forge 43.1.65. Special case when launched trough custom wrapper API > STDOUT switching to ANSI code

Recommended Posts

Problem description:

I have written a rest api with a friend to manage the minecraft session hosted on a Alpine 3.17 in Docker on a Synology NAS (DSM7) using dotnet7.
This is working perfectly on vanilla and also on forge in Windows when started trough the API.

The following applies only when I use Forge on my NAS.
This piece of code works for the first line => sending a welcome message (broadcasted).

            Task.WaitAll(RconWrapper.SendTitleAsync($"Welcome {playerJoined.PlayerName}", MinecraftColor.Yellow));
            Task.WaitAll(RconWrapper.SendMsgAsync(playerJoined.PlayerName, $"Say '{ApiCommand} {ApiHelpCommand}' for available commands"));

The second command never works on forge! It does however on Vanilla minecraft.

This seems to be due to the ANSI escape codes beeing send to STDOUT while runnning it with the script. 
I am relaying the buffer stream to a custom out and error string list. When I retrieve this list with Swagger I get this (notice the starting sequence):

  "\u001b[m\u001b[33m[09:35:44] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file /freshforge/libraries/net/minecraftforge/mclanguage/1.19.2-43.1.65/mclanguage-1.19.2-43.1.65.jar is missing mods.toml file",
  "\u001b[m\u001b[32m[09:35:44] [main/INFO] [ne.mi.fm.lo.mo.JarInJarDependencyLocator/]: No dependencies to load found. Skipping!"

First I believed this must have something to do with Alpine using musl etc.? I tried altering the script to use bash instead of sh but still I get next line escape sequences.
Now, even after filtering the escape sequence in the api, the second command never reaches the server.

This makes sense because obviously something is happening internally after sending the command.
I am a bit at a loss on how to proceed, since troubleshooting on the live machine is no simple task. And I am unfamiliar with what the script does or rather, what the forge jar does!

This is my starting sequence right now with altered run.sh to run and using bash 

                var workingDir = "/freshforge";
                var executable = "bash";
                var args = "run";

I have tried normalizing the send string to ensure it is correctly send. Also tried enforcing unicode from java options, also tried changing the xterm to xterm-mono to avoid it sending ANSI code for coloring,..

Any insight on how to avoid funky behavior when wrapping this script would be appreciated.

EDIT: The problem was that C# was keeping the ANSI escape codes even when normalizing. After a regex replace the problem was resolved. However, the original question remains interesting. Solution => Regex.Replace(line, @"\e\[(\d+;)*(\d+)?[ABCDHJKfmsu]", "");
This actually applies to a number of other situations where you need to get console data out of Linux.
Source:             // Correct regex from : https://social.msdn.microsoft.com/Forums/en-US/635f240a-e586-4a79-8350-b85111365366/how-can-i-strip-off-control-characters-from-a-string?forum=csharpgeneral

Edited by Arythmathicc
The problem was that C# was internally keeping the ANSI escape codes even after normalizing and what not. After a regex replace the problem was resolved. However, the original question remains interesting to avoid the scenario alltogheter.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I have a structure, and sometimes several mobs spawn there. This is a boss and must spawn alone. Here is the code for spawning entities in the structure { "type": "minecraft:jigsaw", "start_pool": "egyptcraft:boss_pyramid/start_pool", "size": 5, "max_distance_from_center": 80, "biomes": "#egyptcraft:has_structure/boss_pyramid", "step": "surface_structures", "start_height": { "absolute": 0 }, "project_start_to_heightmap": "WORLD_SURFACE_WG", "use_expansion_hack": false, "spawn_overrides": { "monster": { "bounding_box": "full", "spawns": [ { "type": "egyptcraft:anubis", "maxCount": 1, "minCount": 1, "weight": 100 } ] } } } Maybe it's something else?
    • I have OreGenEvent.GenerateMinable event, I need to get a chance to spawn (generate) every ore that is processed in this event. Also e.getType().name().toString() is name this is the same block name by which it can be entered in the Block.getByID?  forge 1.12.2 59(recommended)
    • Hello everybody! Out of nowhere my minecraft doesn't allow me to play on forge 1.19.2 I tried to reinstall minecraft, doesn't have any mod right now on the forge version. Tried the newest version of forge, tried recommended version as well. I have the newest version of Java as well...   I dont know why it stopped working but it just stopped completly out of nowhere...   Thank you so much for your help guys ❤️
    • Hello, my world is crashing at 0% loaded and I don't know why. (Forge 43.2.14, 1.19.2) I have two worlds that I play on, and one works and the other doesn't, even with the same mod list. Here's the crash report: https://pastebin.com/AUbRwkGj
    • Minecraft 1.12.2 Very frustrating error. only ever occurs on one device. Started yesterday without prompting (maybe java updated or something?) Says things that have been imported actually arent when running client Reinstalled Intellij, cleared cache, cleaned and rebuilt gradle, redownloaded the entire file from git. Nothing works. (I believe I have the right plugins installed, dependencies OK, and am using corretto 1.8).   One thing I did for more of the below errors was just to explicitly import them, which was working up until this little guy who literally does not exist in forge to import. the class inhereting something inhereting it refers to import net.minecraftforge.registries.IForgeRegistryEntry.Impl, not net.minecraftforge.registries.IForgeRegistryEntry$Impl as the output implies. also I didn't even have to manually import these things for it to work on my other device. (which is just importing the minecraft package that contains them), but here I did have to just to get rid of a few errors--not even make anything work?? I dont know. (edited) here's the aforementioned "below error" (one of many like it): error: cannot access net.minecraftforge.registries.IForgeRegistryEntry.Impl public class BlockBase extends Block {        ^   class file for net.minecraftforge.registries.IForgeRegistryEntry$Impl not found Here's the class BlockBase:   package com.quantum.exodus.common.blocks; import com.quantum.exodus.ExodusMod; import net.minecraft.block.Block; import net.minecraft.block.material.Material; import net.minecraft.creativetab.CreativeTabs; import net.minecraft.item.Item; import net.minecraft.item.ItemBlock; import net.minecraftforge.registries.IForgeRegistryEntry.Impl; public class BlockBase extends Block { protected String name; public BlockBase(Material material, String name) { super(material); this.name = name; setTranslationKey(name); setRegistryName(name); } public void registerItemModel(Item itemBlock) { ExodusMod.proxy.registerItemRenderer(itemBlock, 0, name); } public Item createItemBlock() { return new ItemBlock(this).setRegistryName(getRegistryName()); } @Override public BlockBase setCreativeTab(CreativeTabs tab) { super.setCreativeTab(tab); return this; } }
  • Topics

  • Who's Online (See full list)

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.